Beiträge von stw0307

    Hallo datenknecht,
    vielen Dank für die Antwort.
    ich habe hier mal den Auszug aus der af_xtscript90.php für die Kategorien:


    function ReadCategories()
    {
    global $action;



    echo '<?xml version="1.0" encoding="' . CHARSET . '"?>' . "\n" .
    "<CATEGORIES>\n";


    $cmd = "select categories_id, parent_id from " . TABLE_CATEGORIES .
    " order by parent_id, categories_id";


    $cat_query = xtc_db_query($cmd);
    while ($cat = xtc_db_fetch_array($cat_query))
    {
    echo "<CATEGORIES_DATA>\n" .
    "<ID>$cat[categories_id]</ID>\n" .
    "<PARENT_ID>$cat[parent_id]</PARENT_ID>\n" .
    "<NAMES>\n";


    $cmd = "select language_id, categories_name from " . TABLE_CATEGORIES_DESCRIPTION .
    " where categories_id=" . $cat['categories_id'];
    $names_query = xtc_db_query($cmd);
    while ($names = xtc_db_fetch_array($names_query))
    {
    echo "<NAMEENTRY>\n" .
    "<LANGUAGEID>$names[language_id]</LANGUAGEID>\n" .
    "<NAME>" . htmlspecialchars($names['categories_name']) . "</NAME>\n" .
    "</NAMEENTRY>\n";
    }


    echo "</NAMES>\n" .
    "</CATEGORIES_DATA>\n";
    }


    echo "</CATEGORIES>\n";
    }



    Es stimmt das der CSV Import klappt. Hatte ich auch schon mal getestet. Die categories_id wird beim csv import einwandfrei gesetzt.
    Nur über den Amicronimport kommt entweder die parent_id oder die categories_id nicht ordnungsgemäß zurück.
    Nach dem CSV Import funktioniert der import von Amicron ja auch nicht. Er legt mir dann alle Artikel nochmal je Kategorie an....


    Danke für die Hilfe im voraus

    Hallo Google-Bug,
    ich weiss nicht ob Du schon eine Lösung gefunden hast, aber bei mir hat es mit dem Umschalten auf 4 Kommestellen in Amicron, sowe in seo, bzw XTC geklappt. In Amicron habe ich die Preise netto übertragen.
    Vielleicht hilft das ja.

    Hallo,
    wollt mich mal wieder nach kurzer Krankheit zu dem Problem melden. Amicron konnte mir bei dem Problem nicht helfen. Das Problem liegt wohl daran, dass entweder kein OK vom Shop an Amicron für die Kategorien zurück geliefert wird, oder Amicron mit dem gelieferten OK nichts anfangen kann. Alle Artikel im Admin verschieben wird mit der Zeit nicht funktionieren, da mehrfach am Tag der Artikelbestand und oder neue Artikel hin und her geschickt werden. (ca. 1000 Artikel in unzähligen Haupt und Unter und Unter/Unterkategorien). Die WaWi kann ich nicht wechseln. Hängt zu viel dahinter. Vielleicht habe ich über Wheinachten etwas Zeit und werd mal die af_xtscript90.php und die Def_XTC.xml im Exportordner unter die Lupe nehmen. Ich möchte mich ja eigentlich zügig vom XTC 3.1 verabschieden und auf seo wechseln.....

    Hallo,
    ich habe ein kleines Problem mit dem Artikelexport von WaWi (Amicron) in den Shop.
    In einer Hauptkategorie befinden sich 3 Unterkategorien mit ja 3 Artikeln. Nach dem export wird im Shop die Hauptkategorie so oft angezeigt, wie Unterkategorien mit Artikeln vorhanden sind.
    Bei einer Hauptgruppe mit keiner Untergruppe und nur Artikel in dieser klappt es.
    Als Beispiel:
    Hauptkateorie1
    --Unter1
    --Artikel1
    --Artikel2
    Hauptkategorie1
    --Unter2
    -- Artikel3
    -- Artikel4


    Richtig wäre:
    Hauptkateorie1
    --Unter1
    --Artikel1
    --Artikel2
    --Unter2
    -- Artikel3
    -- Artikel4


    Im Exportfile wird die Kategorie bei jedem Artikel übergeben, aber warum legt es sie bei Untergruppen mehrfach an und ohne Untergruppen richtigerweise nur einmal ?


    Weiß hier jemand weiter?


    Vielen Dank im Voraus :)

    Hallo und vielen, vielen Dank.
    Es hat geklappt. zu meiner Entschuldigung muss ich sagen, dass ich diesen Thread gelesen hatte und auch versucht habe, da ich aber die .htaccess im Export Ordner nicht geändert hatte war das Ergebnis negativ. Dannach hatte ich, wie oben schon geschrieben die Änderung der .htaccess durchgeführt, aber die application_top_export wieder in den Originalzustand gebracht...................
    Manchmal sieht man den Wald vor lauter Bäumen nicht.


    Nochmals vielen Dank, Ihr habt jetzt einen Kunden mehr. Die CE Version werde ich weiter testen und dann die "Bezahlversion" bestellen.
    Ich finde das man solche Arbeit auch honorieren sollte.
    Weiter so.

    Hallo admin,
    vielen Dank für die Antwort.
    Das hatte ich schon probiert, brachte aber keinen erfolg, leider.....


    <Files xml_export.php>
    Order Deny,Allow
    Allow from all
    </Files>


    Auch ein zusatz für die XML Datei "Def_XTC.xml oder *.php brachte keinen erfolg. Ich glaube es liegt an anderen Dateien wie der .../include/application_top_export.php oder anderen, ich gehe gerade die 3 Dateien durch die für den Import und Export von Amicron bei XTC genommen werden. (Im Export Ordner: Def_XTC.xml und xml_export.php sowie im adminordner af_xtscript100 bei der 10'er Version oder af_xtscript90 bei der 9'er von Amicron) Wobei die XML und PHP dateiein bei der 10'er nicht mehr benötigt werden.
    Ich werde weiter testen-- die Nächte am Wochenende sind ja auch noch da....

    Hallo,
    nach weiteren Test und vergleichen mit XTC musste ich feststellen, dass das system soviele Änderungen in machnen Dateien hat, dass die Imprt- und Exportfiles von Amicron nicht zu Seo kompatibel sind.
    Ein Anruf bei Amicron bestätigte meinen Verdacht. Ich muss also auf anpassungen warten. Leider.
    Kann mir wenigstens jemand aus seiner erfahrung sagen, mit welcher WaWi der Shop V2 CE für Artikelexport und Rechnungsimport zusammenarbeitet?
    Danke für eine Antwort.

    Hallo nochmal,
    ich habe fleißig weiter getestet und XT:C 3.04 SP 2.1, sowie Magento 1.4.1.1 erfolgreich mit Import und Export aus der WaWi getestet. Das schließt ein Rechteproblem auf meinem VServer bei Hosteurope wohl aus.(?)
    Ein ändern der .htaccess mit auskommentieren von #Options +FollowSymlinks oder RewriteBase wegen eines Unterordners (Mal mit oder ohne unterordner getestet) brachte keinen Erfolg.
    Ein ändern der .htaccess brachte dann statt dem 403 Fehler nur den Fehler 500 zum Vorschein, der sich auch nach Änderung der .htaccess in seinen Urzustand nicht mehr ändert.


    Gibt es vielleicht einen Eintrag in der .htaccess den ich übersehe?
    Oder liegt es an der .htaccess im Exportverzeichnis?
    Der normale Shop (3.04) läuft zwar, aber ich würde gerne auf die Seo Version wechseln, da er einfach besser ist.
    Großes Lob an die Programmierer, wenn der Export und Import läuft habt Ihr einen Kunden für die Große Version mehr.

    Hallo,
    vielleicht kann mir ja jemand weiterhelfen.
    bei einer Verbindung zwischen Amicron 10.0 und SEO v2 CE erhalte ich beim Import oder Export immer HTTP/1.1 403 Forbidden ().
    OK. Ich weiss das es an den Dateirechten liegt. Mein VServer ist bei Hosteurope.
    Beim "normalen" XT:C 3.04 SP 2.1 ist alles OK.
    Gibt es bei dieser Version Änderungen bei manchen Datei bezüglich der Rechte?


    P.S.: Ein upload der Schnittstellendateien funktioniert in den admin Ordner.


    Vielen Dank für weitere Hilfe.