Beiträge von julien

    Hallo Windmeup,


    funktionierrt alles perfekt. Na dann, können wir beide nur noch hoffen dass unsere Kunden den Merkzettel nutzen und fleissig bestellen.
    :-)
    Sobald ich meinen Shop als beta lade, lade ich dich zum testen ein.


    Guten Verkauf.
    Julien.

    Hallo,


    Ja, Du hast Recht, die Übernahme erfolg korrekt im Warenkorb.
    Allerdings sieht man die Attributen nicht mehr. Im Warenkorb kann man zwar auf dem Artikeln klicken und man landet auf der richtige Optionen, aber als Kunde würde ich es "leicht verwirrend" finden.
    Wenn ich im FF 2 Produkten auf dem Merkzettel habe verschwindet die Möglichkeit nur einzelne Produkten im Warenkorb zu addieren, ich kann nur "alles" übertragen, bei dir nicht?


    Die Lösung mit den Attributen ist extremst cool. Respekt.
    Aber wie Du es erwähnt hast, hat es wahrscheinlich auch im Shop selbst weitreichende folgen.


    Nice week end.
    J.

    Hallo windmeup,


    sei mir nicht böse ich fand nur den Zufall sehr merkwürdig und wollte nicht ,dass man sich mit fremden Feder schmückt.
    Du weisst schon GPL heisst nicht klauen sondern sich gegenseitig helfen und Anerkennung ist die Währung.
    Also, MEIN Fehler. DEINE Version :-) ist nicht meine.


    Jetzt aber zur deine (klein geschrieben) und meine (auch klein geschrieben) Versionen.


    Folgendes hast Du nicht beachtet/übersehen:


    Du verlierst die Attributen wenn Du später mit +- spielst, was zur falsche Bestellung später führt.
    Man kann nur alle oder keine Produkten aus dem Merkzettel in dem Warenkorb addieren .


    Wenn Du meinen Ansatz (mit Anleitung) haben möchtest (die beide Punkten funktionieren) kannst Du dich per PM melden.


    Ich will es nicht hier publizieren da ,So viel ich verstanden habe bringen die Admins (m?)eine :-) Lösung im nächsten Fixpack.


    So, jetzt aber Respekt für deine Mühe.
    Wir basteln alle an dem perfekten Shop.


    Julien.

    Hallo windmeup,


    ja, das würde mich sehr interessieren...
    Da ich die Lösung vor 3 Tage schon für die "plus Version" verbessert und korrigiert, samt Anleitung im plusForum schon gepostet habe...
    Bin ich auf DEINEN Ansatz gespannt.


    :-)

    Hallo Filo30,


    zu erst de positive Nachricht.
    Im Admin Bereich kannst Du wahlweise Deutsch/English (diese Sprachpaket sind mitgeliefert) belassen sodass die Pflege der Artikel wie gewohnt erfolgt unabhängig von der Frontend Sprache.


    Jetzt zur China und Chinesisch.
    Die errechbarkeit der Seite sollte kein Problem sein, da die Seite gehostet wird und egal wo man sich befindet sollte man Zugang zu dem Shop haben. Ob China Russland oder sonst wo. Es bliebe nur noch zu klären ob die "response Time" ok ist (Zeit zwischen Anfrage und Antwort zwischen client und server) und natürlich ob der Content von (der äussert freundliche) VRChina zugelassen ist :-)


    Mit der chinesische Sprache muss ich leider passen, da diese so viel ich weiss bestimmten "charset" benutzt und chinesich ist nicht immer überall als "Mandarin" verstanden...aber da können vielleicht die Admins mehr dazu sagen.


    Auf alle Fälle hast Du vor dir viel Arbeit.
    Aufgeben wäre zu einfach: Mach es!


    Julien

    Hallo bkifft :-)


    einfach ein neues Produkt erstellen der "Sparangebot oder Kombikauf" sich nennt und die Rahmengrösse per Bestellungnachricht abfangen.
    Geht am schnellsten wenn man nur gelegentlich das braucht.


    Julien.

    Hallo,


    da die Version 2.1plus schon zum Verkauf stehe, wundere ich mich wie man diese ohne es "zu sehen" (Admin und Frontend) kaufen kann.
    Bzw. die Entscheidung diese zu kaufen wäre natürlich viel einfacher, es sind immerhin ca. € 250,00. :-)


    Auf commerce-seo ist nur die 2.06, auf seo-templates gar keine.
    Die Suche ergab keinen Treffer.


    Übersehe ich etwas ?


    Mfg,
    J.


    ps: ich meine die 2.1 plus, nicht die CE die noch nicht draussen ist!!

    Hi ishoptv,


    Freue mich über dein Comment und freue mich wenn es "euch" auch weiterhilft.
    Opensource und Community Gedanken: Nehmen aber auch zurückgeben und die anderen Teilhaben lassen.


    Julien.

    Hallo


    admin,
    kannst Du mir einen Besipiel von hässliche Suche die zu nichts führt?
    Meinst Du etwas wie "&(%§$&=)(&" oder etwas wie "èàò" oder etwas wie "o'brian" ?


    Sonst freue ich mich natürlich auf dem nächsten FP.
    :-)


    paulchen,
    freue mich wenn ich helfen konnte. Und wie immer schön auskommentieren und backups machen. Wenn FPs kommen ist es hiermit einfacher den Faden wieder zu finden...


    Julien

    Hallo Paulchen,


    in der letzte Version mit FP11.1 und SEO URLs kannst Du Fehler finden die mit den Schnipsel von oben gefixt werden.


    Suche* nach: o'brian
    (es geht um die ') dann bricht die Suche ab ->Nach dem Fix :Ergebniss zeigt Resultat für o+brian


    Suche nach: (/&(/%)
    dann bricht die auch ab->Nach dem Fix: Ergebniss wird mit "alle" Produkten ersetzt.


    Die Tabellen habe ich dazu addiert weil in manche "alte-neue" Version diese nicht mit dabei waren, also eher Profilaxe.


    Julien.


    *ich kann nur von der CE sprechen , da keine bezahlte Version gekauft.

    Ok,


    für die die eine Community Version haben (die andere Version kann ich nicht testen da nicht gekauft [auf Geschenke freue ich mich immer]) kann man 2-3 Bugs in der Suche fixen in dem man (bitte, immer!!! backups machen!!!):


    a-)2 Tabellen erstellt:

    Code
    1. CREATE TABLE `commerce_seo_url_names` ( `id` int(4) NOT NULL AUTO_INCREMENT, `file_name` varchar(64) NOT NULL, `file_name_php` varchar(32) NOT NULL, PRIMARY KEY (`id`)) ENGINE=MyISAM DEFAULT CHARSET=utf8


    und

    Code
    1. CREATE TABLE `commerce_seo_url_personal_links` ( `link_id` int(4) NOT NULL AUTO_INCREMENT, `url_text` varchar(128) NOT NULL, `file_name` varchar(64) NOT NULL, `language_id` int(2) NOT NULL, PRIMARY KEY (`link_id`)) ENGINE=MyISAM DEFAULT CHARSET=utf8


    b-) in commerce_seo_url.php die Line 115 ersetzt damit die Suche nicht mehr ins leere Läuft.

    Code
    1. //header('Location: '.HTTP_SERVER.DIR_WS_CATALOG.'404.php?error=404');header('Location: advanced_search_result.php?n=1&keywords=');


    c-)nicht gewünschte Zeichen äüößèé etc.. ausfiltert bzw ersetzt: diese Funktion kopieren und ausrufen in advanced_search_result.php


    Code
    1. function clean_str($str,$empty_string){ // Sonderzeichen mit ae, ue ect.. ersetzen: $bad = array("ä", "ü", "ö", "ß", "Ä", "Ü", "Ö",); $good = array("ae", "ue", "oe", "ss", "AE", "UE", "OE",); $str = str_replace($bad, $good, $str); //Akzenten ersetzen $str = strtr($str, 'àáâãåòóôõøèéêëçìíîïùúûÿñ', 'aaaaaoooo0eeeeciiiiuuuyn'); //Exoten ersetzen $str = preg_replace('%[^a-z0-9]%siU',$empty_string,$str); //Doppelte $empty_string ersetzen $count = 1; while($count) $str = str_replace($empty_string.$empty_string, $empty_string, $str, $count);//Ausgabereturn $str;}


    und

    Code
    1. xtc_redirect(xtc_href_link('keywords/'.$_GET['keywords']));


    ersetzen mit

    Code
    1. xtc_redirect(xtc_href_link('keywords/'.str_replace(' ','+',clean_str($_GET['keywords']," "))));


    im selben File.


    So, ich glaube hier vielleicht ein bisschen geholfen zu haben, bitte trotzdem testen und bescheid sagen.



    Julien.
    ps: da ich seeehhhhrr sensibel bin, bitte Sachlich bleiben ;-)

    Hallo,


    also bei mir funktioniert es.
    Zuerst:
    Hast Du dein Shop in einem Unterverzeichnis und dieser in der .htaccess eingegeben?
    Hast Du die "modulen" richtig konfiguriert und installiert...ich weiss klingt doof, aber gehe vielleicht jeden einzelnen Schritt noch einmal durch. (unter Admin->Konfig->Seo Url benutzen...und unter Module->Seomodule->direct URL richtig konfigurieren und starten. Dann das Cache leeren.


    Sag uns wie es läuft.
    Julien.

    Ok.


    Die commerce_seo_url.php wird aufgerufen weil Du die SEO url am laufen hast :-)
    Hast Du unter :


    - Admin->Konfiguration->Meta&Suchmaschine->Suchmaschinenfreundliche URLs benutzen? auf true gesetz?
    - Admin->Module->cSEO MODULE->commerce:SEO URL v1 installiert und gestartet ?


    und der Cache geleert/gelöscht?


    Bei mir auf ein frisches Install funzt alles perfekt. Habe es extra nochmals getestet.


    Julien.


    ps: der o'Brian Bug ist glaube ich nirgendwo hier gelöst...man musste nachschauen wie man die ' aus dem Suchfeld parsen kann.

    Hallo,


    gehe mal in der File rein und lasse dir den Query ausgeben, oder anders gesagt füge vor Line 40 in commerce_seo_url.php folgende Zeile:
    echo "SELECT cn.file_name_php FROM commerce_seo_url_names AS cn JOIN commerce_seo_url_personal_links AS cp ON cp.url_text = '".mysql_escape_string($_GET['linkurl'])."' AND cn.file_name = cp.file_name LIMIT 1";


    Und sage mal was da rauskommt.


    Julien.

    Ahhaaa..jetzt verstehe ich.


    Abwarten und Tee trinken... Rechtstreit ist nie schön deshalb hoffe ich eher auf einen sauberen Wettbewerb.
    Da XT/SEO auf Community aufbauen, Quellcode offen sind und einiege Jahren am Markt sich etableiren konnten kann ich mir kaum vorstellen dass einen "One-man-Show" ohne kritische Masse etwas dagegen machen kann..
    Wenn dann, wird es rein Betriebswirtschaftlich auf eine maximum an Kompatibilität setzen um eine Kanibalisierung zu Ermöglichen...
    Wir, die User, können nur davon profitieren. Konkurenz belebt das Geschäft...


    Bin auf die Zukunft gespannt und belieb SEO treu (auch wenn das Warten auf dem letzten FP mich /&%$/§&%$ hat)
    :-)


    julien.