Beiträge von Siggit

    Dann muss ich wohl die Software wechseln ...... Dann hätte es auch keine CE Version geben dürfen wenn vorn herein geplant ist die Open Source Version nur für kommerzielle Zwecke zu nutzen.

    Hallo!


    Ich bekomme im Admin die Meldung, Diese Version wird nicht mehr unterstüzt! Bitte aktualisieren Sie auf die v3. Ich verwende aktuell die CE 2.5.11


    Irgendwie ist wohl vergessen worden, wenn so eine Meldung kommt auch einen entsprechenden Download zur Vefügung zu stellen.:?::?::?:


    Siggi

    Hallo!


    ich habe eine Testinstallation duchgeführt bei aktivierten SSL. Wenn ich mich im Admin anmelde kekomme ich eine Fehlermeldung im Footer "Die Abfrage wurde abgebrochen, kontaktieren Sie den Administrator..."

    ich lande dann auf der Registrierungseite mit dieser Fehlermedlung.

    ich habe die .htacess umbenannt der Fehler kommt trotzdem. SSL Zertifikat ist letsEncrypt .


    wo kann der fehler her kommen?


    ich habe noch folgendes gefunden die Textausgabe der Fehelrmeldung mommt wahscheinlich aus der cseo_db.inc.php bzw cseo_dbv7.inc.php


    CODE in der cseo_db.inc.php ab Zeile 47 oder ab Zeile 52 in der cseo_dbv7.inc.php


    function xtc_db_error($errno, $errstr, $errfile, $errline) {


    switch ($errno) {

    case E_USER_ERROR:

    if ($errstr == "(SQL)") {

    // handling an sql error

    if ($_SESSION['customers_status']['customers_status_id'] == 0) {

    echo "<b>SQL Fehler</b> [$errno] " . SQLMESSAGE . "<br /><br />\n\n";

    echo "<b>Query:</b> " . SQLQUERY . "<br /><br />\n\n";

    echo "Beim Aufruf der Datei <em>" . SQLERRORFILE . "</em> ";

    echo ", PHP " . PHP_VERSION . " (" . PHP_OS . ")<br /><br />\n\n";

    }

    xtc_db_query("REPAIR TABLE sessions");

    xtc_db_query("REPAIR TABLE whos_online");

    xtc_db_query("REPAIR TABLE whos_online_month");

    xtc_db_query("REPAIR TABLE whos_online_year");

    echo "<b>Die Abfrage wurde abgebrochen, kontaktieren Sie den Administrator...</b><br /><br />\n\n";

    // Send an email to the shop owner if a sql error occurs

    if (defined('EMAIL_SQL_ERRORS') && EMAIL_SQL_ERRORS == 'true') {

    $subject = 'Datenbankfehler - ' . STORE_NAME;

    $message = '<font color="#000000"><strong>' . $errno . ' - ' . SQLMESSAGE . '<br /><br />' . SQLQUERY . '<br /><br />Request URL: ' . $_SERVER['HTTP_HOST'] . $_SERVER['REQUEST_URI'] . '<br /><br /><small><font color="#ff0000">[CSEO SQL Error]</font></small><br /><br /></strong></font>';

    require_once (DIR_FS_INC . 'xtc_php_mail.inc.php');

    xtc_php_mail(STORE_OWNER_EMAIL_ADDRESS, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS, '', '', STORE_OWNER_EMAIL_ADDRESS, STORE_OWNER, '', '', $subject, nl2br($message), $message);

    }

    } else {

    echo "<b>My ERROR</b> [$errno] $errstr<br />\n";

    echo " Fatal error on line $errline in file $errfile";

    echo ", PHP " . PHP_VERSION . " (" . PHP_OS . ")<br />\n";

    echo "<b>Die Abfrage wurde abgebrochen, kontaktieren Sie den Administrator...</b><br />\n";

    }

    exit(1);

    break;


    case E_USER_WARNING:

    case E_USER_NOTICE:

    }

    /* Don't execute PHP internal error handler */

    return true;

    }





    Danke

    Hallo.


    Ich bin nicht mehr in den admin Bereich gekommen und habe alles wieder ohne SSL laufen.


    Ich habe folgende Fehlermeldung in der error.log des Shops bekommen:


    [16-Jan-2018 15:13:43 Europe/Berlin] PHP Fatal error: require(): Failed opening required '/homepages/36/d123456/htdocs/meine-domain/shop//homepages/36/d123456/htdocs/meine-domain/shop/includes/functions/compatibility.php' (include_path='.:/usr/lib/php5.6') in /homepages/36/d123456/htdocs/meine-domain/shop/admin/includes/application_top.php on line 122


    in der Zeile 122 der appliction_top php steht folgender Code


    require(DIR_FS_CATALOG . DIR_WS_FUNCTIONS . 'compatibility.php');


    DIR_FS_CATALOG bezieht sich hierbei auf das Shopverzeichnis und DIR_WS_FUNCTIONS auf Pragrammbibliothken, wieso kann die comaptiblity.php bei aktivierten SSL nicht geöffnet werden?


    Danke

    Gibt es denn kein fertiges Script, dass die Shopsoftware auf SSL umschreibt. Bei anderen gibt es sowas auch auch oder es gibt eine Anleitung wie man vorgehen muss. Ich habe das Thema am 29.11.2017 gestartet und bis heute noch keine Antwort oder einen Tipp erhalten. Wenn ich gewußt hätte das die Unterstützung hier nur so minimal ist, hätte ich eine andere Softwärelösung bevorzugt.

    Hallo!


    Habe das SSL Zertifikat aktiviert, die Seite wird auch mit https:// aufgerufen. Habe in den configue.php unter /admin/includes und /includes

    define('ENABLE_SSL', true); eingestellt.


    Desweiteren habe ich alle Links meines Contents auf https:// umgestellt (Bilder, externe und interne Links).

    bekomme immer noch ein Ausrufezeichen (Firefox) angezeigt, die Seitenlinks der Navigation zeigen nur auf http:// und nicht auf https://.

    welche Datei oder Dateien sind für die Umwandlung der Links zuständig oder wo kann ich das im Backend bewerkstelligen.

    Müssen noch weitere Einstellungen vorgenommen werden um den Shop komplett mit https:// zu betreiben da die ganze Software ursprünglich für http Protokoll geschrieben wurde.


    Es funktioniert so nur bedingt, mit diesen Änderungen war die Admin Oberfläche nur noch eine weiße Seite. Habe alles wieder zurückgesetzt, damit es überhaupt funktioniert.


    Danke



    Hallo Dieter,


    ich habe bei mir eine Artikelnummer in die Suche eingegeben egal ob Backend oder Frontend es kommt ein Ergebnis. Ich habe auch nach EAN gesucht das geht auch.

    Welche Version verwendest du? Hast evtl. was verstellt in den Artikeleinstellungen. Überprüfe nochmal, ob du die Artikelnummer richtig vergeben hast in den Grundeinstellungen des Produkts, ob das Produkt auch aktiv ist und die Schreibweise im Suchfeld.


    Grüße Siggi:)

    Also ist die Shopsoftware für ein große Objekt in dieser Art völlig ungeeignet. Wenn ich 20 Kunden am Tag habe mag das noch gehen, wenn es dann aber 50 bis 100 sind dann ist das vom Zeitaufwand nicht mehr zu bewerkstelligen.
    Es sollte ja auch so sein, dass dieser Zugang zeitlich begrenzt sein sollte.

    Hallo!


    Ich kenne dein Template nicht, heir bekommst eigentlich selten Antworten, warum das so ist erklärt sich eigentlich von selbst wenn du dir die Webseite des Shopsystems betrachtest.


    Untersuche die html Seite doch einfach mal mit dem Addon Firebug für Firefox, evtl bekommst du raus wo der img Tag gesetzt wird. Damit kannst du testen und wenn du die Einstellung hast dann erst sichern bevor du die Seite aktualisierst, sonst fängst du wieder von vorne an. Wenn die CSS ausgelagert ist musst du diese dir diese auf deinen Server holen und anpassen.
    Es ist so dass über die cseo_css.php die Stylesheet Datei geladen wird und auf fremden Servern kann man ja nichts bearbeiten.
    Schau mal hier!
    CSS erstellen auf deinen Server laden am besten Subdomain style.deine-domain.de und komprimieren nicht vergessen wegen der Ladezeiten des Shops.


    Beispiel:

    Code
    1. <a href="http://meine-domain.de/Zielseite/" target="_self"><img alt="alternativer Linktitel"src="/templates/v2next-boot-flat/img/startseite/bild.jpg" style="width: 400px; height: 300px;" title="Bildtitel"></a><br>


    Das ist der Pfad zu meinem Stylesheetverzeichnis mit Unterverzeichnis img/startseite/ (Bilder für die Startseite)

    Code
    1. /templates/v2next-boot-flat/img/startseite/


    Wie du das hinbekommst mit der CSS ist ja hier beschrieben.


    Evtl kannst du das auch in der Shop Grundkonfiguration machen, ich kenne ja deinen Shop nicht und sehe wie sich der Fehler darstellt.


    Noch ein Tipp um die Ladezeiten des Shops zu optimieren kannst du Google PagespeedInsight oder gtmetrix.com zum testen verwenden. Die meisten Einstellungen dafür lassen sich via .htaccess Datei steuern (vor der Berabeitung sichern). Es kann auch zu Server Fehlern führen und mann sucht dann ewig nach dem Fehler in dem Fall einfach per ftp überschreiben und weiter probieren.


    Viel Glück.

    Hallo!


    Ich bin noch auf der Suche nach einer Shopsoftware in der sich ein Benutzer registrieren und zusätzlich nach Bezahlung eines Jahresbeitrages einen geschützten Bereich aufrufen kann.
    Ist das mit dem Content Manager möglich. Habe hier keine Funktion gefunden in der es die Möglichkeit gibt die Informationsseiten zu registrierten Seiten zu machen.


    Danke

    Hallo!


    Habe gerade die CE 2.5.1 auf Host Europe mit WebPack M installiert. In diesem Paket funktioniert modrewrite nicht was aber für SEO Urls notwendig ist.
    Ich habe von einer anderen Installation die .htaccess verwendet da kommt dann kommt diese Fehlermeldung:
    .....................................................................................
    Das Skript konnte nicht fehlerfrei ausgeführt werden.
    Bitte prüfen Sie Ihr
    Error-Logfile auf die genaue Fehlermeldung. Dies finden Sie im KIS unter
    "Administration > *IHR PRODUKT* > *IHR PAKETNAME* > Logfiles".
    Weitere Informationen finden Sie auch in unseren FAQ.
    .....................................................................................
    ALso htaccess wieder umbenannt und es geht wieder. In den error logs des Shops und bei Hosteuroppe sind die Fehler nicht zu finden. Also habe ich SEO Urls wieder abgeschaltet.
    Es geht zwar wieder aber das ist ja auch nicht die Lösung, ohne .htaccess hat jemand eine Lösung. Ich finde den Fehler nicht aber für die Performance wäre die .htacess schon nicht schlecht.


    Danke

    Hallo!


    Ich habe meinen Artikeln verschiedenen Atrribute wie Gewicht und Farbe zugewiesen. Jetzt ist das Problem, dass diese Artikel ohne die Angabe der Artiklemerkmale trotzdem bestellt werden können was aber nicht Sinn und Zweck der Sache ist. Wie kann ich die Artikelmerkmale als Pflichtangabe aktivieren.
    Es muss ja eine UND Verknüpfung zwischen dem Artikel und den Artikelmerkmalen hergestellt werden.
    Oder ist es möglich ein entsprechendes Artikelmerkmal z.B 1 kg (2,3,4,5 kg als weitere Optionen) schon als Voreinstellung zu nutzen.
    Also wenn nichts geändert wird, dass dann automatisch 1 kg bestellt wird.


    Danke

    Hallo! :?:


    Ich suche eine Möglichkeit dem Kunden bei bestimmten Produkten jpg bzw PDF Dateien als :?: Upload hinzuzufügen.
    Gibt es mittlerweile hierfür im admin eine Lösung?


    Das Thema wurde schon 2011 mal aufgegriffen ich finde aber im Admin in den Artikelmerkmalen keinen Ansatz für den Dateiupload im Produkt.


    Wie kann ich den dateiupload als Attribut hinzufügen. Es gibt ein XT Commerce Modul: Upload von Dateien im Produkt es ist mir aber zu riskant dieses Modul einzusetzen, da ich nicht weis ob ich mir damit den Shop zerschieße. Die Struktur z.B. der Templateordner würde dabei im root liegen was schon nicht stimmen kann.
    Vielleicht kann ja sich ja mal jemand das Modul ansehen und anpassen.


    Danke.

    Hallo! :?:


    Ich habe folgendes Problem.


    Im Shop gibt es gleichartige Artikel die in verschiedenen Verpackungseinheiten abgegeben werden.


    Beispiel:


    Artikel 1 - Farbe blau
    1,0 kg
    5,0 kg
    10,0 kg


    Mein Ziel ist es den Artikel so aunzulegen.


    Artikel 1 - Farbe blau vorhandene Menge = Gesamtgewicht (Bsp: Gesamtgewicht 500 kg)
    Jetzt soll über Master Slave oder Artikel Attribute bei jeder Bestellung das Gewicht des bestellten Artikel abgezogen werden.


    Bsp.:


    Kunde kauft im Shop
    Artikel 1- Farbe blau: 2 * 5,0 kg
    Artikel 1- Farbe blau: 1 * 10, kg


    Im Warebestand sollte dann das Gewicht der bestellten Artikel direkt abgezogen werden.


    Gesamtgewicht vor der Bestellung: 500 kg
    Gesamtgewicht nach der Bestellung: 480 kg


    Wenn dann der Warenbestand (Menge Bsp: 50 kg) unterschritten hat, kann ich ja eine Warenbestandswarnung ausgeben per Mail lassen.


    Gibt es hierfür eine direkte Lösung oder kennt jemand ein passendes Modul.


    Habe auch noch nicht gefunden wie ich Master-Slave Produkte anlegen kann oder wo ich diese Funktion aktivieren muß. :?:


    Danke!

    Hallo!


    Danke für die Antwort. Aber telefon steht dor schon auf true.
    Es geht mir um das ganz normale Kontaktformular.


    Dort steht nur:


    Ihr Name:
    Ihre E-Mail Adresse:
    Ihre Nachricht:
    usw.


    Ich bereits schon mal einen Thread eröffnet . So weit war ich da schon einmal aber es kam dann kein Eingabefeld für die Telefonnumer sonder nur die Textausgabe.


    Siggit

    Hallo!


    Ich habe bereits vor längerer zeit einen ähnlichen Thread eröffnet auf den es aber nie eine Antwort gab.
    Also stelle ich die Frage erneut. Wie ist es möglich das Kontaktformular um mehrere felder zu erweitern.
    Eine Telefonnummer als Zusatzfeld wäre nicht schlecht um die Kunden auch telefonisch zu erreichen bei dringenden Anfragen.


    Habe nicht im admin dazu gefunden also muss es programmiert werden. Wo muß ich eingreifen damit es auch als Telefonnumer.


    shop_content.php aber wie??? und wie gehts weiter???


    Danke