Kupon wird nicht übergeben

  • Hallo,


    so bin nun leider wieder auf ein Problem gestoßen. Und zwar habe ich nun im Shop einen Kupon angelegt mit bestimmten Gültigkeiten.


    habe bisher alles wie in http://support.commerce-seo.de…nen/page6?highlight=kupon


    auch durchgeführt und somit auch den Bug mit der Error Message behoben. Ich kann den Kupon eingeben und im oberen Bereich der Shopping_Cart wird auch der Hinweis ausgegeben über den Kupon und ich kann auch den Link mit den Infos zu dem Kupon aufrufen und habe genau meine Einstellungen.


    Wenn ich aber nun weiter gehe zu checkout_payment.php wird die Auswahl Guthaben / Gutschein verwenden nicht aktiviert!


    Ich kann aber ein Gutschein einlösen und somit mit meinem Guthaben zahlen, das nutzen wir nun auch schon einige Monate ohne Probleme.


    Auch im Adminbereich ist
    ot_coupon auf 19
    ot_discount auf 20
    ot_gv auf 21


    Hat wer eine Idee wo ich noch schauen könnte?


    Gruß
    ohmann

  • So nun nach langen Testen habe ich weitere erkenntnisse bekommen:


    1. Der Kupon wird verrechnet, aber nur im letzten Schritt der Bestellung!


    2. Punkt 1 geht nur wenn der Kupon NICHT auf einen Artikel bezogen ist! Komisch aber wahr.. wenn ich die Kategorie nehme geht der Kupon.


    Dennoch wird der Gutschein nicht in den Punkten wie zb. Shopping Card mit einberechnet! Und ich bin nun den Fred wie oben angegeben nun schon einige male durchgegangen.

  • Vielen Dank für die zahlreichen Antworten! Schön das es Foren gibt!


    Leider besteht dennoch weiterhin das Problem: Kupon kann nicht eingelöst werden wenn eine Produkt-ID angegeben wird. Bei Kategorienbezogen funktioniert der Kupon!


    PS: vorsicht ironie im ersten Satz!

  • Der Kupon wird immer erst im letzten Schritt verrechnet. Das der Gutschein NUR ohne Produkteingrenzung funktioniert, ist ein Uralt Bug von xtc, den wir bisher leider noch nicht 100% gelöst haben.

    <p>Wir geben nur Anregungen und Hilfestellung auf Basis unserer Erfahrung, keine Rechtshilfe!<br>\m/('_')\m/</p>