Umstellung auf ein SSL Zertifikat. Welche Dateien ändern?

  • Hallo!
    Ich brauche dringend Hilfe, ich hoffe ihr könnt mir weiter Helfen.
    Und zwar hatte ich bis jetzt SSL-Proxy und möchte jetzt auf SSL-Zertifikat umnstellen. Die nötigen Dateien (configure.php + /admin/includes/configure.php , application_top.php) habe ich schon geändert. Es müsste aber noch irgendwo eine Datei geben, die ich noch ändern muss. Und zwar werden die ganzen Grafiken auch automatisch über den SSL-Proxy geleitet. Und diese EInstellung muss ich wieder ändern.
    Weiß jemand evtl. in welcher Datei ich was ändern muss?


    Würde mich über jede Hilfe freuen.


    Vielen Dank schgon mal!


    Gruß
    Dennis

  • Die Umstellung erfolgt nur in den 2 configure.php Dateien. Da ist sicher etwas im Content Manager noch drin??? Da musst DU die Inhalte anpassen und wenn Du im Template noch feste Verknüpfungen drin hast.

    <p>Wir geben nur Anregungen und Hilfestellung auf Basis unserer Erfahrung, keine Rechtshilfe!<br>\m/('_')\m/</p>

  • Vielen Dank für die schnelle Antwort.


    Also es sind nicht nur meine eingesetzte Grafiken die Probleme bereiten sondern auch die vom Template, Farbverläufe, Buttons, Hintergründfarben, etc. Sobald ich auf SSL umstelle werden gar keine Grafiken angezeigt, nur Text. Deswegen habe ich die Vermutung dass es irgendwo noch eine bearbeitende Datei oder ein Eintrag gibt, die automatisch vor der Grafik den passenden SSl-Proxy setzt.


    Evtl. noch eine Idee?


    Vielen Dank!

  • Das sind definitiv diese beiden Dateien. Da muss! irgendwo ein Fehler sein. Bitte mal die header.php und metatags.php nach diesem SSL Proxy durchsuchen. Die URL ist noch auf diesem ssl.web... gesetzt!

    <p>Wir geben nur Anregungen und Hilfestellung auf Basis unserer Erfahrung, keine Rechtshilfe!<br>\m/('_')\m/</p>

  • Danke für den Tipp!


    Ich habe dort mal geschaut und folgendes gefunden:

    PHP
    1. //$http = (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER).DIR_WS_CATALOG;
    2. //$http = DIR_WS_CATALOG;
    3. $http = (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER).DIR_WS_CATALOG;
    4. $js_http = (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER).DIR_WS_CATALOG;


    Kann es sein, dass es hier was eingetragen wurde und der originale Eintrag auskommentiert wurde?
    Kenne mich mit php gar nicht aus, deswegen solche blöde Fragen :D


    Vielen Dank schon mal!

  • Der Wert: HTTPS_SERVER steht in der includes/configure.php. Da musst Du nachschauen.
    Eventuell sind ja die Änderungen in der configure.php NICHT übernommen worden, weil die im Betrieb ja auf NUR LESEN stehen sollte, somit Änderungen nicht geschrieben wurden???!!!

    <p>Wir geben nur Anregungen und Hilfestellung auf Basis unserer Erfahrung, keine Rechtshilfe!<br>\m/('_')\m/</p>

  • Vielen Dank für die Antwort! Die Rechte habe ich vor dem Überschreiben schon geändert. Die Datetein wurden definitiv überschrieben. Das habe ich überprüft.


    Nur zur Sicherhet. Stimmen diese Einträge?->

    PHP
    1. define('HTTP_SERVER', 'http://www.obramo-security.de'); // eg, http://localhost - should not be empty for productive servers define('HTTPS_SERVER', 'https://www.obramo-security.de'); // eg, https://localhost - should not be empty for productive serveer define('ENABLE_SSL', true); // secure webserver for checkout procedure?


    PHP
    1. define('HTTP_SERVER', 'http://www.obramo-security.de'); // eg, http://localhost - should not be empty for productive servers
    2. define('HTTPS_SERVER', 'https://www.obramo-security.de'); // eg, https://localhost - should not be empty for productive servers
    3. define('HTTPS_CATALOG_SERVER', 'https://www.obramo-security.de'); // eg, https://localhost - should not be empty for productive servers



    Vielen Dank!

  • So ist es korrekt. Bleibt aber die Frage offen, wo das eingetragen wurde:

    Eventuell doch in der includes/modules/metatags.php ???

    <p>Wir geben nur Anregungen und Hilfestellung auf Basis unserer Erfahrung, keine Rechtshilfe!<br>\m/('_')\m/</p>

  • Folgendes habe ich dort gefunden:

    PHP
    1. <?php
    2. $url = explode('?', $_SERVER['REQUEST_URI']);
    3. ?>
    4. <link href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) .$url[0] ; ?>" rel="canonical" />
    5. <meta name="revisit-after" content="<?php echo META_REVISIT_AFTER; ?>" />


    kannst du damit was anfangen?


    Vielen Dank schon mal!

  • Schau mal in den Quelltext. Da steht base=...ssl.webpack... im Header Bereich. Das stimmt nicht. Das andere ist alles korrekt.



    Ja, im Moment steht da ssl.webpack weil ich das ganze wieder rückgängig gemacht habe, da nichts mehr funktioniert hat. Ich würde dann morgen wieder auf ssl umstellen und noch mal schauen was dort dann steht.


    Aber ich sehe, dass sich Herr Siekiera wieder meldet, habe schon die Hoffnung aufgegeben. Wenn der Herr Siekiera so gnädig wäre und uns einen entscheidenen Tipp geben könnte?? Somit könnte ich viel Zeit, Nerven und Geld sparen.


    Vielen Dank!

  • Alles scho feddich... Hab den Shop komplett auf SSL umgestellt. Und natürlich gleich getestet :)



    Vielen Dank! Das ist super! Da bin ich froh, dass es geklappt hat. Kannst du bitte uns noch verraten wo was geändert werden musste? Das interessiert mich mitlerweile sehr :-)


    Eine Kleinigkeit aber noch, die Verbindung ist aber nur teilweise verschlüsselt. Es müsste noch irgendwo eine Grafik sein, die das verursacht, denke ich. Es sind aber keine Grafiken aus dem Content Manager, es müsste also noch was im Template sein. Denn im verschlüsseltem Bereich, ist alles unwichtige ausgeblendet, also nur das nötigste um den Verkauf abzuschließen. Es sind, zumindest nicht Sichtbar, keine von mir eingebundenen Grafiken auf den verschlüsselten Seiten.
    Und die Grafiken sind bei mir so eingebunden: <img src="images/tornado.jpg"


    @siekiera
    das war letztens auch der Grund, warum du damals den ganzen Shop automatisch auf ssl.webpack umgepolt hast :D


    Weis echt nicht voran es noch liegen sollte. Würde mich über jede Hilfe freuen!


    Danke und Gruß


    Dennis

  • ich schon wieder :o


    folgendes steht bei noch im Quelltext:

    Code
    1. <meta name="revisit-after" content="14" /><!--base href="http://www.obramo-security.de/" /--><base href="https://ssl.webpack.de/obramo-security.de/" />


    Muss ich noch irgendwo was ändern?


    Evtl. in der xtc_redirect.inc.php? Dort sehe ich noch was von dem blöden SSL-Proxy:


  • Es kann auch ein Javascript sein, was per http eingebunden ist und nicht per https!!! Mal im Template Ordner bei javascrip nachsehen.

    <p>Wir geben nur Anregungen und Hilfestellung auf Basis unserer Erfahrung, keine Rechtshilfe!<br>\m/('_')\m/</p>