Unterseiten können nicht aufgerufen werden

  • Hallo in die Runde, ich verwende commerce:SEO V1.1.1 und hab leider einige Probleme. Der momentan größte Fehler denn ich habe ist, dass man nicht auf die Unterseite gehen kann, um die Produkte von 21 bis x in der Kategorie angezeigt zu bekommen. Es werden immer nur die Produkte 1-20 angezeigt :o Die URL der zweiten Seite ist komischerweise gleich zu der für Seite 1. Das direct url v3 plugin ist installiert, aktuell aber auf false gestellt. Suchmaschinenfreundliche URLs steht auch auf false. Hab an diesen Einstellungen schon etwas rumgespielt, da ich gerne Direct URL v3 nutzen wollen würde. Das Plugin ging bei mir nicht, bekomme immer eine 404 Seite trotz (meiner Ansicht) richtigen Installation. Die .htaccess ist aktuell nicht angelegt Vielen Dank für eure Hilfe!
  • Hi! Das Problem mit der 404 nach der Aktivierung von direct URL v3 hatte ich auch. Die Lösung war eine erste Indexierung nach dem Einschalten des Plugins. Steht im PDF der Shopinstallation drin, überliest man aber sehr leicht... Viel Erfolg, Marc
  • Habe jetzt beides komplett ausgeschaltet (Suchmaschinenfreundliche URLs benutzen: false & directURL:false) aber es tut sich 0,0. 20 Produkte, mehr will er mir nicht zeigen. Die URL zu den Produkten 21-40 ist /shop/index.php?cPath=12_21& Ist das richtig so?
  • Das [B]cPath=12_21[/B] ist der Kategoriepfad. In Deinem Beispiel bist Du in der Unterkategorie 21 der Hauptkategorie 12. Mit Produkten hat das erstmal garnichts zu tun. Sind denn die Produkte überhaupt aktiviert? Die kommen aus einer Schleife und können nicht einfach nach 20 abbrechen es sei denn jemand hat die Scripte manipuliert. Denn DirectURL hat mit der Produktanzahl soviel gemeinsam wie der Sack Reis in China. In Deinem Fall dürfte wohl ein anderes Problem vorliegen. Eventuell hast Du ganz tolle Sonderzeichen in einem Produktnamen verwendet, die da überhaupt nichts zu suchen haben? Beliebt ist hier zum Beispiel das " (Zoll), was sämtliche Scripte lahmlegt. Kann man sich das anschauen? Hab meine Glaskugel verliehen...
  • Vielen Dank soweit für eure Hilfe. Ja, soweit hatte ich die Syntax auch verstanden. Was müsste denn nach dem & angezeigt werden, um die weiteren Produkte angezeigt zu bekommen? Habs jetzt fürs erste mit Methode Holzhammer gelöst: Die Maximalzahl der Produkte die pro Kategorie angezeigt werden, habe ich auf 100 erhöht. Einzig Klammern () sind in den Produktnamen drin, könnte es dadurch zu Problemen kommen?
  • [quote='kartfreund','http://support.commerce-seo.de/index.php/Thread/?postID=3430#post3430'] Was müsste denn nach dem & angezeigt werden, um die weiteren Produkte angezeigt zu bekommen? [/QUOTE] Verstehe ich nicht. Wenn Du schon wieder die Kategorie URL meinst, die hat immer noch nix damit zu tun. Wie ist die URL damit wir uns das anschauen können?
  • So [I]kartfreund[/I], alter Spezi... Nachdem Du mir Deinen FTP geschickt hattest, hab ich mir das mal angesehen. Ich schreibe das hier, damit keiner sowas macht wie Du :-P 1. während der Installation schon die www Adresse angeben, denn eine www Umleitung legt sonst alles lahm. Habe die beiden configure.php Dateien angepasst 2. nicht die .htaccess leer machen wenn DirectURL laufen soll... die ist wieder gefüllt. Diesmal korrekt ;) Nu läuft alles wie es soll: [URL]http://www.sqracing.de/shop/[/URL] PS: Trage mal unter Metatags-/Suchmaschinen sämtliche Daten ein. Und ne neue Adminseite haste auch :)
  • Ich dank euch! Wäre ich jetzt nicht drauf gekommen, hatte die Installation nur schnell durchgezogen. Vielen vielen vielen Dank. Bleibt noch die Frage, wie ich einen Rabatt von mehr als 10% (gewünscht 20%) für einzelne Kundengruppen anlegen kann.
  • [quote='siekiera','http://support.commerce-seo.de/index.php/Thread/?postID=3638#post3638']So [I]kartfreund[/I], alter Spezi... Nachdem Du mir Deinen FTP geschickt hattest, hab ich mir das mal angesehen. Ich schreibe das hier, damit keiner sowas macht wie Du :-P 1. während der Installation schon die www Adresse angeben, denn eine www Umleitung legt sonst alles lahm. Habe die beiden configure.php Dateien angepasst 2. nicht die .htaccess leer machen wenn DirectURL laufen soll... die ist wieder gefüllt. Diesmal korrekt ;) Nu läuft alles wie es soll: [URL]http://www.sqracing.de/shop/[/URL] PS: Trage mal unter Metatags-/Suchmaschinen sämtliche Daten ein. Und ne neue Adminseite haste auch :)[/QUOTE] Tag siekiera ich habe fast das gleiche Problem Kategorien leiten an die Fehler Seite 404 sowie auch die produktseite an Fehler Seite 404 gibt es Einleitung wie man die configure.php und die .htacces richtig konfiguriert ich teste gerade Version 1.1.1 auf revido.de Server mit eingeschaltete MOD_ReWrite Test Shop: [url]www.werner-schrauben.de/shop[/url] vielen Dank im Voraus
    [B][I][FONT="Comic Sans MS"] [url]www.wernerschrauben.de[/url] Commerce:SEO V1.1.1 CE Server bei : revido.de Mod_ReWrite : On [/FONT][/I][/B]

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von wissam ()

  • [CODE]# .htaccess for Direct URL # (c) 2007 Ing. Michael Fürst # # angepasst von Sebastian Schramm und Daniel Siekiera # Blog Integration - Daniel Siekiera RewriteEngine On # COMMENT THE FOLLOWIN LINE, IF YOU GET AN ERROR 500 (Internal Server Error) Options +FollowSymlinks # SET THE FOLLOWING LINE, IF YOUR SHOP RUNS IN AN SUBFOLDER. ALSO IF YOU GET AN ERROR 500 (Internal Server Error) ON SOME SYSTEMS # EXAMPLE: If your shop is located at www.yourdomain.com/shop set the following line: "RewriteBase /shop" RewriteBase /shop/ # Onlie use Rewrite Engine, if Directory or File not exist RewriteCond %{REQUEST_FILENAME} -f [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^(.+) - [PT,L] RewriteRule ^(.*)(.+)404.php$ 404.php [qsappend,L] RewriteRule ^(.*)(.+)\.html$ commerce_seo_url.php?linkurl=$1$2 [qsappend,L] RewriteCond %{REQUEST_FILENAME} !\.html$ [OR] RewriteRule ^(.*)$ commerce_seo_url.php?linkurl=$1 [qsappend,L] ErrorDocument 404 /404.php[/CODE]Ja, das gleiche, schau in die .htaccess, denn die zieht bei Dir nicht. RewriteBase sollte auf /shop/ stehen.

    Wir geben nur Anregungen und Hilfestellung auf Basis unserer Erfahrung, keine Rechtshilfe!
    \m/('_')\m/