DirectURL v3 und "Mehr über..."

  • Sobald ich die "DirectURL v3" einschalte, gehen unten bei "Mehr über..." die Links nicht mehr. Ich werde immer wieder nur auf die Startseite zurückgeschickt - die Url's zu dem "Content" sind schlicht weg. Schalte ich "DirectURL v3" wieder aus, bekomme ich zwar die Links wieder und kann den "Content" aufrufen aber nicht mehr mit den suchmaschienenfreundlichen Url's (http://********.de/shop_content.php?coID=4). Ich mein, ich kann damit zur Not leben aber der Sinn ist es doch nicht oder? Zumal ich beim Abschalten der "DirectURL v3" wieder folgende Fehlermeldung bekomme:


    Zitat

    1146 - Table 'd00a7dcd.bluegate_seo_url' doesn't exist


    TRUNCATE TABLE `bluegate_seo_url`


    [XT SQL Error]


    Schalte ich "DirectURL v3" an ist die Fehlermeldung weg aber ich kann die AGB, Widerrufsrecht, Impresum usw. nicht mehr aufrufen weil die Links wech sind :confused:

  • Ich habe das Problem gelöst. Man muss (!) bei jedem neu eingestellten Artikel die Indexierung "DirectURL v3" neu starten! Ich habe das jetzt so gemacht, dass ich täglich Produkte einstelle - also bis alle wieder drinne sind - und dann einmal täglich die Indexierung starte. Ratsam ist es aber, nach 1-5 neuen Produkten oder wenn im Backend Änderungen vorgenommen wurden die Indexierung neu zu starten, weil sonst die Kunden die Produktlinks und natürlich auch alle rechtlichen Links ( Widerufsrecht, AGB, Impressum usw. ) nicht mehr aufrufen können, was zu rechtlichen Problemen bei dem Betreiber führen könnte ;)


    Also öfters mal die Indexierung starten wenn neue Artikel eingestellt werden, sonst können die Links nicht mehr aufgerufen werden ;)


    Ich glaube Deine Frage in DEINEM anderen Thread hat sich dann damit auch erledigt - wenn es bei Dir auch so funktioniert, was ich mal denke ;)

  • Seltsam! Lässt Du Deine Sessions über die Datenbanken laufen? Was ist mit Deinem Cache auf dem Srver auf dem der Shop liegt? Mal die Datenbanktabellen optimieren ( alle markieren ) über phpMyAdmin und dann optimieren lassen?

  • ;) nein, hab nicht an der htaccess gefummelt *lach*


    cache benützen ist bei mir übrigens auf "false" *grübel*
    Datenbank cache ist auch auf false ... ist das gut so? ich glaub ja nicht


    mod_rewrite muss ich mal suchen ... wo hab ich jetzt das wieder gelesen??

  • ;) nein, hab nicht an der htaccess gefummelt *lach*


    cache benützen ist bei mir übrigens auf "false" *grübel*
    Datenbank cache ist auch auf false ... ist das gut so? ich glaub ja nicht


    Hehe, ok, habe ich auch so.


    mod_rewrite muss ich mal suchen ... wo hab ich jetzt das wieder gelesen??


    Bei welchem Provider bist Du bzw.liegt Dein Shop?


    Nachtrag:


    Jetzt bekomme ich auf Deiner Seite die Meldung:


    Zitat

    Not Found


    The requested URL /XTCsid=00bd87c560baaa16da9a3e5ecb410ecb was not found on this server.

  • ok, ich bin bei all-incl. com
    ich schraube hier übrigens an einem Mac, aber das sollte hier nichts ausmachen.

    Zitat

    Zitat:
    Not Found


    The requested URL /XTCsid=00bd87c560baaa16da9a3e5ecb410ecb was not found on this server.


    Öhm ... ich hab die freundlichen Suchmaschinen wieder auf false gestellt.
    Seither komme ich zwar bei jedem Klick wieder auf die Startseite, aber damit ist es auch vorbei mit weiterkommen.
    Ich mach mal diesen DirectUrl wieder weg ... dann müsste es als Gast ja gehen.

  • Bei allinkl sollte mod_rewrite eigentlich an sein. Ich weiss nur nicht, ob ich das damlas habe anschalten lassen oder es generell an ist. Hattest Du schon einmal einen ähnlichen Shop über diesen Privider laufen? Hast Du Dich genaustens an die Installationsanleitung von xt-commerce 304sp2.1 gehalten, gerade die Ordner Rechte?


    Nachtrag:


    Funktioniert übrigens wieder alles, ich kann jetzt alles aufrufen ;) Was hast Du gemacht?


    Nachtrag 2:


    Du solltest unbedingt schnell Deine rechtlichen Pflichten bezüglich Widerufsrecht, Versandkosten, Steuernummer, Impressum usw. nachkommen ;)

  • Trotzdem musst Du die Umsatzsteuer ID im Impressum angeben und die Versandkosten ;)


    http://www.linksandlaw.info/Im…t-Notwendige-Angaben.html
    http://www.e-recht24.de/news/ecommerce/275.html


    Ferner würde ich das Widerufsrecht und die Versandkosten in den im Shop extra angegebenen Stellen eintragen, schon der Übersicht halber ;)


    Nachtrag:


    Die "Privatsphäre und Datenschutz" würde ich auch nicht leer lassen ;) Willst Du Dir mal meinen Shop, der gerade neu aufgesetzt wird, ansehen? Ich schicke Dir dann ein Mail mit den Link ;)