SSL aktivieren CE 2.5.1

  • Hallo!


    Habe das SSL Zertifikat aktiviert, die Seite wird auch mit https:// aufgerufen. Habe in den configue.php unter /admin/includes und /includes

    define('ENABLE_SSL', true); eingestellt.


    Desweiteren habe ich alle Links meines Contents auf https:// umgestellt (Bilder, externe und interne Links).

    bekomme immer noch ein Ausrufezeichen (Firefox) angezeigt, die Seitenlinks der Navigation zeigen nur auf http:// und nicht auf https://.

    welche Datei oder Dateien sind für die Umwandlung der Links zuständig oder wo kann ich das im Backend bewerkstelligen.

    Müssen noch weitere Einstellungen vorgenommen werden um den Shop komplett mit https:// zu betreiben da die ganze Software ursprünglich für http Protokoll geschrieben wurde.


    Es funktioniert so nur bedingt, mit diesen Änderungen war die Admin Oberfläche nur noch eine weiße Seite. Habe alles wieder zurückgesetzt, damit es überhaupt funktioniert.


    Danke



    2 Mal editiert, zuletzt von Siggit () aus folgendem Grund: admin / Backend kam nur noch eine weiße Seite

  • Gibt es denn kein fertiges Script, dass die Shopsoftware auf SSL umschreibt. Bei anderen gibt es sowas auch auch oder es gibt eine Anleitung wie man vorgehen muss. Ich habe das Thema am 29.11.2017 gestartet und bis heute noch keine Antwort oder einen Tipp erhalten. Wenn ich gewußt hätte das die Unterstützung hier nur so minimal ist, hätte ich eine andere Softwärelösung bevorzugt.

  • Hallo.


    Ich bin nicht mehr in den admin Bereich gekommen und habe alles wieder ohne SSL laufen.


    Ich habe folgende Fehlermeldung in der error.log des Shops bekommen:


    [16-Jan-2018 15:13:43 Europe/Berlin] PHP Fatal error: require(): Failed opening required '/homepages/36/d123456/htdocs/meine-domain/shop//homepages/36/d123456/htdocs/meine-domain/shop/includes/functions/compatibility.php' (include_path='.:/usr/lib/php5.6') in /homepages/36/d123456/htdocs/meine-domain/shop/admin/includes/application_top.php on line 122


    in der Zeile 122 der appliction_top php steht folgender Code


    require(DIR_FS_CATALOG . DIR_WS_FUNCTIONS . 'compatibility.php');


    DIR_FS_CATALOG bezieht sich hierbei auf das Shopverzeichnis und DIR_WS_FUNCTIONS auf Pragrammbibliothken, wieso kann die comaptiblity.php bei aktivierten SSL nicht geöffnet werden?


    Danke