Versandkosten werden erst falsch angezeigt (Bestellprozess)

  • Hallo, in meinem Shop habe ich folgendes Problem. Beim Bestellprozess werden in der [B]shopping_cart.php[/B] die Versandkosten falsch angezeigt bzw. nicht berechnet. Wenn man dann weiter klickt und auf der [B]checkout_shipping.php[/B] landet ist alles so wie es sein soll. Ich nutze das dp-Modul (Post) und berechne nach Gewicht. Bis 5 kg = 4,90€, Bis 9kg = 9,95€ usw. Gewichte sind alle richtig hinterlegt. Wenn aber ein Gesamtgewicht von z.B. 5,1 kg im Warenkorb liegt wird erst (shopping_cart.php) [B]Deutsche Post - Versand nach DE: (1 x 0 kg) (Deutschland): 4,90 EUR[/B] angezeigt und dann, eine Seite weiter (checkout_shipping.php) steht es richtig [B]Versand nach DE: (1 x 5.1 kg) 9,95 EUR[/B]. Ist das Problem auch schon bei anderen Usern aufgetreten? Kann mir evtl. jemand Tips geben wo der Fehler liegt. So kann der Shop natürlich nicht "scharf" gehen. Vielen Dank im Voraus. Grüße Steffen
  • Hallo, hat keiner eine Idee? Wenn der Kunde nicht durchgängig die richtigen Versandkosten angezeigt bekommt kann ich den Shop nicht ins Netz stellen. Darum nochmals meine Bitte um Eure Hilfe zu o. g. Problem. Vielen Dank und ein schönes Weihnachtsfest. Steffen
  • Versuch mal in der includes/classes/class.shipping_estimate.php folgendes: Vor folgendem Code: [CODE]$quotes_array = array();[/CODE] das mal einbinden: [CODE]$total_weight = $_SESSION['cart']->show_weight();[/CODE] Wenn das klappt, kommt es im nächsten Update. In der Plus ist das schon länger behoben :-)

    Wir geben nur Anregungen und Hilfestellung auf Basis unserer Erfahrung, keine Rechtshilfe!
    \m/('_')\m/