Commerce:seo Fehler ohne Ende & Hilfe ???

  • Guten Abend,
    ich habe direkt ein paar Fragen.


    Warum wird die Hilfe hier so erschwert?
    Wenn man bei Google sucht, zB. nach: "commerce:seo weiße seite" kommt man ins Forum welches ja auf vBulletin läuft.
    Anstatt dort dann wenigstens über die Frage zu stolpern findet man sich im Hauptmenü Eures Forums wieder, so etwas ist schon mal mehr als schlecht!


    Dies gibt Kunden und auch neuen Kunden ein Gefühl der Verarsche, denn anstatt etwas zu finden was man sucht, findet man sich nur im Hauptmenü wieder, dort auch Fehlanzeige, denn man muss die Suche nutzen, um seine Frage beantwortet zu bekommen, dies geht aber auch nur wenn man sich anmeldet (So wie ich dies nun gemacht habe), ich weiß nicht wer bei Euch hier so schlau war dies so zu gestalten aber Kunden unfreundlicher geht es schon garnicht mehr, ich dachte Ihr wollt hier auch was verkaufen!
    Habe dies mal aul überflüssigen Inhalt an Google geschickt, das Netz braucht nicht noch merh Seiten die zu nichts führen!


    Last Euch mal richtig beraten wie man ein Geschäft oder auch ein Hilfeforum aufzieht!
    So etwas ist mal richtig schlecht, kommt einen ein wenig rüber wie Kiddies und nicht wie Geschäftsläute.


    Des weiteren werden Kritiken hier eh nur sehr schlecht angenommen, lieber alles schnell löschen ist hier die diviese (viele Berichte im Internet gefunden wo sich User beschweren wenn Sie kritisieren), so etwas ist auch Kindergarten, entweder man hat ein Forum und ein Produkt und möchte Meinungen hören oder nicht!
    Soviel ersteinmal zu Eurem Forum, kommen wir nun mal zum Shopsystem.


    Fehler ohne Ende ist noch milde ausgedrückt.
    Nach einen Serverumzug wollte ich mich nun einloggen, Fehlanzeige weiße Seite, der Server hat die selbe Konfiguration wie der alte Server.


    Dieses Problem ist bei Euch auch bekannt, zumindest geht es sehr vielen Kunden des Shopsystems so, die Lösung die ich gefunden habe ist recht einfach.
    Die Freigabe der Files und Ordner muss genau so wiederhergestellt werden wie sie mal war, ich poste das ganze mal damit man es mal was genauer hat, feht übringens auch in Euren Angaben (mal ein wenig erweitern wäre nicht schlecht)!


    Ordner die per SSH (Konsole) oder FTP Client freigegeben werden müssen:


    OSCOMMERCE: FREIGABE


    chmod 777 /Euer Verzeichniss/includes/configure.php
    chmod 777 /Euer Verzeichniss/includes/configure.org.php
    chmod 777 /Euer Verzeichnisst/admin/includes/configure.php
    chmod 777 /Euer Verzeichniss/admin/includes/configure.org.php
    chmod 777 /Euer Verzeichniss/templates_c/
    chmod 777 /Euer Verzeichniss/cache/
    chmod 777 /Euer Verzeichniss/admin/images/graphs
    chmod 777 /Euer Verzeichniss/admin/backups/
    chmod 777 /Euer Verzeichniss/images/
    chmod 777 /Euer Verzeichniss/images/categories/
    chmod 777 /Euer Verzeichniss/images/categories_org/
    chmod 777 /Euer Verzeichniss/images/banner/
    chmod 777 /Euer Verzeichniss/images/products_movies/
    chmod 777 /Euer Verzeichniss/images/product_options/
    chmod 777 /Euer Verzeichniss/images/product_images/info_images/
    chmod 777 /Euer Verzeichniss/images/product_images/original_images/
    chmod 777 /Euer Verzeichniss/images/product_images/popup_images/
    chmod 777 /Euer Verzeichniss/images/product_images/thumbnail_images/
    chmod 777 /Euer Verzeichniss/images/product_images/mini_images/
    chmod 777 /Euer Verzeichniss/admin/templates_c/


    Nach der Freigabe gilt es einige Files schreibsicher zu machen dies wären dann die folgenden:


    chmod 444 /Euer Verzeichniss/includes/configure.php
    chmod 444 /Euer Verzeichniss/includes/configure.org.php
    chmod 444 /Euer Verzeichniss/admin/includes/configure.php
    chmod 444 /Euer Verzeichniss/admin/includes/configure.org.php


    Dann sollte auch wieder alles klappen und es wird keine weiße Seite merh angezeigt!


    Soviel zur Problemlösung des ganzen.
    Nun ergibt sich aber ein weiteres Problem was mich auch gezwungen hat mich bei Euch anzumelden.


    Der Shop läuft nun ganz so wie er soll, aber wenn ich ein neues Produkt hinzufügen will, erhalte ich schon wieder (wie soll es anders sein) eine weiße leere Seite.
    Was nun?


    Nun seit Ihr gefragt, welche Datei muss man freigeben um Waren in den Shop eintragen zu können?
    Wo liegt das Problem diesmal?



    Verstehe nicht wie man es bis heute nicht hinbekommt, eine Abfrage zu intigrieren die checkt ob die entsprechenden Files mit den richtigen Rechten versehen wurden, wenn nicht dann muss einem das gesagt werden und dies könnte ein kleines Script erledigen.


    Also wieso kann das ein Oscommerce, ein Magento, ein Prestashop usw.?
    Das ganze Shopsstem ist wirklich nicht für den Produktiven Einsatz gedacht, wenn es bis dato noch solche Fehler gibt!


    Hoffe troz meiner ganzen Kritik auf Hilfe.
    Solltet Ihr das ganze wieder löschen wollen so wie bei dieversen anderen Usern setze ich es online, Text ist gespeichert und bei den Platformen im Netz auch schnell verteilt!

  • So das beim einstellen neuer Produkte immer eine weiße leere Seite kommt hat anscheinend folgenden Hintergrund.
    Die Bilder die man bei dem neuen Artikel mit angibt werden nicht gespeichert, bzw, übernommen, warum auch immer.


    Schreibrechte sind natürlich gesetzt (chmod 777), geht aber immer noch nicht?
    Man ist das ein sch.... basteln, ich hasse solche sachen wie die Pest.


    Und hier darf man ja uch nicht auf allzuviel Hilfe hoffen.

  • Scheint wohl an den Nutzerrechten zu liegen, warum habe ich die nict obwohl ich admin bin?
    Schrott Shop!


    Wenn ich schon als admin eigeloggt bin und ein Bild hochlade, warum hat es dann nicht automatisch die Nutzerechte?
    Wie dämlich ist das denn diesen Fehler hat kein mir bekannter Shop außer dieser hier.


    Wie umgehe ich den Mist?

  • Scheint wohl an den Nutzerrechten zu liegen, warum habe ich die nict obwohl ich admin bin?
    Schrott Shop!


    Wenn ich schon als admin eigeloggt bin und ein Bild hochlade, warum hat es dann nicht automatisch die Nutzerechte?
    Wie dämlich ist das denn diesen Fehler hat kein mir bekannter Shop außer dieser hier.


    Wie umgehe ich den Mist?


    Also ich sehe nicht wirklich Server Adminstration kentnisse!?


    Weiter, mal ganz schnell typed, weil Du baut ziemlich mist!


    Hmm


    Tja wer so etwas macht wie Du:
    Kein Forumregel beachten, also meckern übers gleiche in mehrer forumteilen ist nicht wirklich normalo.!
    Kein einzige info über den wichtigste sachen:
    Wie version
    Settings:
    Server settings:
    Hoster:
    Versionen die aufs server sind
    Htaccess


    LINK


    Ja oder nein updated oder standard template, ein reines install mit standard template lauft fast überal bei jede gute hoster!


    Wen es nicht lauft ist oder den server / settings nicht in ordnung, oder macht man ein fehler beim installl / settings oder modulen / template


    Ach ja sind vielen die es benutzen und kein oder fast kein probs haben.


    Die fehler kommen oft durch dejeneige hinter den Tastatur , weil wir sind Mensch und die macht mal fehler!



    Wen man also reines neuinstall, mit richtige oder kein htaccess macht ( wen kein dan seourl aus)
    DB cache aus weil lauft nicht auf viele server und iwchtige sachen werden auto cached.


    Wen umzug tja dan soll man die richtig machen, oder wen man es nicht kan einer dafür beauftragen.


    Du sacht bist Kunde, wirklich wwarum dan nicht in Plusforum wo man extra Support bekomt weil dan ist man Kunde, ( Paket gekauft)


    Wen nicht gekauft ist man benutzer!


    Service kan man aber kaufen / buchen für ce aber auch den kauf version, umzug machen die von COMSEO ziemlich oft, .


    Wen wir es machen, immer einer reine neusintall mit basis neuversion und alles standard dan testen.
    Damit sol man wen probs naturlich erstmal anfangen, wen es mit hilfe den server error und access logs nicht beheben läst.
    Wen dies lauft dan kan man den teilen van Datenbank umsetzen unsw.
    Weil meist ist doch etwas anders dan vorher.


    und wen man komplettes DB mitnehmt, tja mit cache an und seourl installed fragt man um probs, weil naturlich nimt man dan auch noch einiges an altes caCHE UND SESSIONS UND UND MIT DIE NaTURLICH AUF EIN ANDERE SERVER NICHT LAUFEN WERDEN.
    Du sagt 1 auf 1 mirror, wen so spricht das für solches!



    ich denke nicht das Du einfach weiter hilfe bekommen werdet mit so ein Ton und so ein einstellung!
    Forum regel und und


    Hier lauft es bei mehreren Kunden in mehrere Versionen auf mehrere Server mit unterschiedliche Hoster und settings weiter auch Lokaal mit ein art XAMP


  • Tja sehe mein beitrag vor diese und sehe ins ROT oscommerce ist es definitief nicht hier!


    Weiter den Rechten in jedenfal den neue kauf versionen haben so ein script die checkt, wen Du altes oder etwas anderes benutzt, tja...


    Zitat

    ie Lösung die ich gefunden habe ist recht einfach.
    Die Freigabe der Files und Ordner muss genau so wiederhergestellt werden wie sie mal war,


    Von welches Planet komst Du ist/war doch immer al so bei jeden XTFORK, und also doch kein 1 auf 1 mirror, weil dan war dies auch gesetzt worden!


    Nur ein ganz wichtige bemerkung, SSH, FTP und und oder Apache User tja welches server benutzer/user setzt die Rechten und ist den file owner wen man es so macht!


    Weiter dieser Hilfe Forum ist durch und mit hilfe von USER, wen Kunde ( kauf version hat man ein Support Forum wo es auch wirkliche Support von den Entwickler gibt)


    Also wen man hier hilfe braucht soll man mindestens Lesen / und an algemeine Forum regeln halten, aber wie Du selbe sagt Du hat so einiges an erfahrung und weist ganz genau wie es sein soll und gehörd oder?

  • Es geht immer noch um die Freigabe fürs commerce:seo!
    es scheint ein Problem bei den Rechten zugeben und zwar in der Besitzer Gruppe die z.B. die 1002 hat, wenn ich nun aber ein Blid hochlanden möchte (Produktbild) dann wird dieses eingetragen mit 33 33, aslo muss ich wohl die Gruppe ändern.


    Der Server arbeitet mit einer Spieglung, also erzähl mir bitte nichts über Server.
    Kenne keinen Shop, wie ich schon sagte bzw. schrieb, der zu blöd ist nach dem aufsetzen, Bilder hoch zu landen, das geht bei Magento, Oscommerce, Bigware usw.


    Also bitte daher keine Belehrung, Commerce:seo ist einfach zu schlecht programmiert, das zeigen doch allein schon die ganzen Bugs die es hier im Forum zu diskutien galt.
    Daher finde ich es erstanlich das soetwas auch noch verkauft wird, dafür würde ich nichts ausgeben wollen, bei solchen Problemen, nein Danke!

  • Nur ein ganz wichtge bemerkung, SSH, FTP und und oder Apache User tja welches server benutzer/user setzt die Rechten und ist den file owner wen man es so macht!


    Den ganzen Satz bitte nochmal auf Deutsch, Danke.

  • Es geht immer noch um die Freigabe fürs commerce:seo!
    es scheint ein Problem bei den Rechten zugeben und zwar in der Besitzer Gruppe die z.B. die 1002 hat, wenn ich nun aber ein Blid hochlanden möchte (Produktbild) dann wird dieses eingetragen mit 33 33, aslo muss ich wohl die Gruppe ändern.


    Der Server arbeitet mit einer Spieglung, also erzähl mir bitte nichts über Server.
    Kenne keinen Shop, wie ich schon sagte bzw. schrieb, der zu blöd ist nach dem aufsetzen, Bilder hoch zu landen, das geht bei Magento, Oscommerce, Bigware usw.


    Also bitte daher keine Belehrung, Commerce:seo ist einfach zu schlecht programmiert, das zeigen doch allein schon die ganzen Bugs die es hier im Forum zu diskutien galt.
    Daher finde ich es erstanlich das soetwas auch noch verkauft wird, dafür würde ich nichts ausgeben wollen, bei solchen Problemen, nein Danke!



    Ganz einfach wen es auf einer lauft dan machst Du den fehler selbst auf die Anderer und wirklich nicht den COMSEO, wen es auf keiner noch nicht lauft soll man es richtig installieren und Konfigurieren, wen man so etwas nicht kan , tja dan soll man die finger davon lassen und wen man comseo benutzen möchtet dieser kaufen mit ein Install service, wen man hat scheinbar dan selbe nicht die richtige kentnis oder geduld sich die Installation mit alle einstellungen und und richtig zu setzen.


    Tja ein mirror hmmm was soll ich sagen .......... wen es 100% wirklich gleich ist kan es so nicht sein also..., weil wie vorher gesagt durch dir, musste den Rechte noch angepasst werden, dan ist es kein 100 pro mirror!

  • Nur ein ganz wichtge bemerkung, SSH, FTP und und oder Apache User tja welches server benutzer/user setzt die Rechten und ist den file owner wen man es so macht!


    Den ganzen Satz bitte nochmal auf Deutsch, Danke.


    Danke suche dir weiteres hilfe, bin aus Holland und bemuhe mich, aber Du ... tschussie

  • Es geht immer noch um die Freigabe fürs commerce:seo!
    es scheint ein Problem bei den Rechten zugeben und zwar in der Besitzer Gruppe die z.B. die 1002 hat, wenn ich nun aber ein Blid hochlanden möchte (Produktbild) dann wird dieses eingetragen mit 33 33, aslo muss ich wohl die Gruppe ändern.


    Der Server arbeitet mit einer Spieglung, also erzähl mir bitte nichts über Server.
    Kenne keinen Shop, wie ich schon sagte bzw. schrieb, der zu blöd ist nach dem aufsetzen, Bilder hoch zu landen, das geht bei Magento, Oscommerce, Bigware usw.


    Also bitte daher keine Belehrung, Commerce:seo ist einfach zu schlecht programmiert, das zeigen doch allein schon die ganzen Bugs die es hier im Forum zu diskutien galt.
    Daher finde ich es erstanlich das soetwas auch noch verkauft wird, dafür würde ich nichts ausgeben wollen, bei solchen Problemen, nein Danke!


    Tja VERSION noch immer nicht bekant gegeben!, anscheinend kein Kauf version weil dan war es in PLUS suport forum!
    Wen man den aktuele versionen nicht zum laufen bekommt macht man etwas falsch.


    Und ja BUGS gibt es überall sehe dein Forum nach von den Rest Shopsystemen, bin dabei seit 2000 also...

    Schlimme BUGS aber nicht in den Aktuele (Kauf) Versionen von COMSEO. und auch nicht in den v2.1plus v2.2 plus v2.3 plus und den Aktuele v2next plus


    Aber OK wen einer es nicht an laufen bekomt sollte es den COMSEO sein die fehler hat, trotzdem vielen es seit mehrere Jahren laufen haben?

  • Kaufen würde ich es schon allein aus dem Grund nicht das es jetzt schon so beschissen ist!
    Allein das hält einem vom Kauf ab!


    Ich gebe doch kein Geld aus für Probleme, was ist das denn für ne Logik?
    Jedes andere Shopsystem ließ sich bisher ohne Problem auf einen anderen Server umziehen, es gab keinerlei Fehler.


    Dieses System macht nur Ärger, werde es jetzt ganz einfach machen, steige wieder auf alt bewertes um, dies war ein 2 Monats Test bei dem es fast kaum zu Problemen gekommen ist, selbst Fabanpassungen tec. hat man ganz gut hinbekommen, aber soetwas darf nach einem einfachen umzug auf einen anderen Server nicht passieren!


    Daher sehe ich den Test als misslungen an.
    Nutze wieder die Shops die immer laufen und fertig.


    Der Name verlockt einfach zum Testen, aber die Arbeit hätte man sich sparen können.
    Zu Dir, Du sagts Du bist aus Holland?
    Das ist nett von Dir das Du probierst zu helfen, nur bringt das ganze recht wenig wenn man nur die hälfte versteht, ich könnte Dir jetzt auf Türkisch schreiben in halben Deutsch, das würde Dir auch nicht wirklich weiter helfen oder?


    Auser das Du sagst ich solle mich mal mehr mit dem und dem beschäftigen, war da nichts was zurLösung des Problems beigetragen hat.


  • Tja auser Weiser Seite und Rechten prob hast Du nur gemeckert ;)


    Naturlich werdet so keiner problem behoben, den wirkliche Server / PHP error und und ist hier durch dir gar nicht posted!
    Von was umgezogen ? von gleiches COMSEO auf ein gleiches comseo version?


    Weil das geht immer wen die settings comseo und hosting identisch sind, noch niemals fehler gehabt, nur aufpassen wie gesagt mit den sessions und caching weil die soll man naturlich nicht mitnehmen, weiter gibt es ein extra security in jedenfal in den plus version, ( wo man dan vielleicht noch was machen muss, wen dieser werten auf den server abweicht)

  • hulisuis, das Problem mit den Benutzerrechten bzw Eigentümern der Dateien sollte sich von deinem Hoster mit einer Mail erledigen lassen, es scheint so, als würden die Shopfiles dem einen User "gehören" , z.b. dem ssh/ftp-user, beim Bildupload z.B: wird aber ein anderer user verwendet, nennen wir ihn Web-user - dadurch treten dann hin und wieder solche Probleme auf, kommt sehr selten und nur bei einigen Hostern vor, das ist also nicht die Regel, von vielleicht 75 Shopmigrationen und Umzügen die ich mit commerce:seo gemacht habe trat es vielleicht 2-3 mal auf (bin Shopdienstleister, daher die hohe Anzahl).


    ich hab den Beitrag hier nur überflogen, was das Thema Geld ausgeben angeht : die Plusversion ist kein Vergleich zu der CE Version, die CE wird m.E. sehr stiefmütterlich behandelt, bei der kostenpflichtigen Version ist vieles um längen besser - u.a. der Support im Forum für die Bezahlkunden.


    Mit besten Grüßen aus Hamburg!


    Mario


  • Hallo Mario


    Habe so etwas vorher gesagt aber er versteht mein Deutsch nicht ;)


    Zitat

    Nur ein ganz wichtge bemerkung, SSH, FTP und und oder Apache User tja welches server benutzer/user setzt die Rechten und ist den file owner wen man es so macht!


    Wen man mirrors macht sol man es richtig machen und nicht halb ;)
    Er weiss auch besser wie ein Forum sein soll, also..

  • So, nun auch mal von mir eine Aussage:
    Wir können immer mit Kritik umgehen. Das hat sich in den letzten Jahren auch drastisch verbessert.


    zu Deinem Problem:
    Shop lag auf dem alten Server und funktionierte korrekt? Sehe ich das richtig?


    Nach Shop Umzug kamen die Probleme!


    Also woran liegt es dann jetzt? Meine Auffassung: Der Umzug auf den neuen Server ist nicht korrekt vollzogen worden. Wenn der Shop vorher lief und jetzt nicht mehr, liegt es doch in 1. Linie am neuen Server und dessen Einstellungen!!!


    Zu den Berechtigungen: Wenn wir jede Datei abfragen, ob sie denn die richtige Berechtigung hat, dauert alles mindestens doppelt so lange. Das wollen und werden wir nicht tun, denn bei der Installation werden die Berechtigungen abgefragt.


    Zu Deinem eigentlichen Problem: Eine weiße Seite bedeutet IMMER Server Fehler. Du solltest Dich also als allererstes mal an Deinen Provider wenden und nach dem error_log fragen!!! Da steht nämlich der Fehler dann auch drin. Mit diesem Fehler können wir dann auch was anfangen. Der Rest ist Rätselraten, besonders wenn es ja vorher funktioniert hat. Das ist halt das Problem, alles kostenlos haben wollen und am lautesten schreien, wenn was nicht geht.


    P.S.: Server, bei denen man 777 Rechte geben muss, sind meiner Auffassung nach sowieso hochgradig gefährlich. 777 bedeutet ALLE dürfen ALLES! Hier solltest Du dich mal fragen, ob die Serverwahl hier die richtige war. Unser Forum ist jetzt direkt auf unserer Seite integriert und Google hat wohl noch nicht alle Links umgestellt. Sollte sich in Zukunft bessern.

    <p>Wir geben nur Anregungen und Hilfestellung auf Basis unserer Erfahrung, keine Rechtshilfe!<br>\m/('_')\m/</p>

  • Rede ich eigentlich mit der Wand? Wir brauchen eine konkrete Fehlermeldung, die steht im error_log und die bekommt man im Zweifel beim Provider! ALLES ANDERE IST RÄTSELRATEN AUS KALTEN KAFFEESATZ!!!!

    <p>Wir geben nur Anregungen und Hilfestellung auf Basis unserer Erfahrung, keine Rechtshilfe!<br>\m/('_')\m/</p>