Update eingespielt -> ehlermeldung im Adminbereich

  • Hallo


    Ich habe eben den Patch von http://www.commerce-seo.de/qui…-commerceseo-v231-ce.html eingespielt.
    Nun bekomme ich die Meldung, dass ich angeblich die Version "commerce:SEO 2.3.6 Plus" hätte und darunter steht:

    Zitat

    Es konnte nicht genau ermittelt werden, welche Version Sie verwenden! Sollten Sie bereits ein Update eingespielt haben, installieren Sie bitte im Admin noch unter Module > Installation / Update den Fix. Hierbei wird auch Ihre Datenbank aktualisiert.
    Bitte wenden Sie sich im Zweifel an den Support.


    Ich vermute mal, dass da am Patch was nicht stimmt.
    Eigentlich sollte ich nun die Version 2.3.2CE haben ...


    Was kann man tun?


    LG
    Bernd

  • Hat noch niemand den Patch eingespielt?
    Ich würde ihn auch gerne installieren, aber leider habe ich kein Testsystem. Und der Shop muss laufen.
    Also wenn es positive Meldungen vom Patch einspielen geben würde, wüsste nMedien sicher auch, dass es generell gehen müsste.


    Gruß Jens

  • Hallo


    Ich habe mal einen Testshop aufgesetzt.
    Hier ist genau das gleiche passiert. Es sind zwar auch ein paar Dateien geändert, jedoch keine, die im Update angefasst wurde.


    Der Shop scheint ansonsten jedoch zu laufen. Ich konnte bislang zumindest kein Problem feststellen.


    Gruß Bernd

  • Hallo


    Ich habe mir eben den Patch mal angesehen. Da scheint schlicht ein kleiner Fehler drinnen zu sein.


    Folgende änderungen in der Datei admin/includes/modules/install/cseov231_qf2.php scheinen das Problem zu beheben.
    Zeile 57 von

    Code
    1. xtc_db_query("UPDATE database_version SET version = 'commerce:SEO 2.3.6 PLUS'");


    zu

    Code
    1. xtc_db_query("UPDATE database_version SET version = 'commerce:SEO 2.3.2 CE'");


    und Zeile 66 von

    Code
    1. xtc_db_query("UPDATE database_version SET version = 'commerce:SEO 2.3.5 PLUS'");


    zu

    Code
    1. xtc_db_query("UPDATE database_version SET version = 'commerce:SEO 2.3.1 CE'");


    ändern.


    Danach über Modul - Installation/Update das Update noch einmal deinstallieren und wieder installieren. Nun schaut bei mir alles gut aus.


    Eine bestätigung eines Admins/Programmierers ob das alles ist wäre nett.

  • Hier ist scheinbar Urlaubszeit.
    Aber wenn es ein wichtiger Patch wäre, hätte sicher was als Erläuterung dabei gestanden.
    Ich hoffe ein Admin ist bald wieder da und bestätigt deine Vermutung.


    Gruß Jens

  • Nachdem du geschrieben hast, dass der Fix geändert ist, habe ich ihn neu von eurer Seite gezogen und bei mir ausgeführt.
    Die Version wird nun richtig

    Zitat

    Version: commerce:SEO v2.3.2 CE

    angezeigt.
    Trotdem kommt die Fehlermeldung:

    Zitat

    Es konnte nicht genau ermittelt werden, welche Version Sie verwenden! Sollten Sie bereits ein Update eingespielt haben, installieren Sie bitte im Admin noch unter Module > Installation / Update den Fix. Hierbei wird auch Ihre Datenbank aktualisiert.
    Bitte wenden Sie sich im Zweifel an den Support.


    Den Patch kann ich auch nicht mehr deinstallieren, da die Schaltfläche immer Installieren anzeigt.


    Ich hoffe, dass der Shop trotzdem noch läuft, da ich ihn in einem scharfen Shop eingespielt habe.


    Gruß Jens

  • Hallo


    Ich habe mir den neuen Fix auch noch einmal angesehen. Da ist immer noch ein Fehler drinnen.
    In der Datenbank wird die Version "commerce:SEO v2.3.2 CE" eingetragen.
    Das ganze muss aber wohl "commerce:SEO 2.3.2 CE" sein. Wenn man das von Hand in die Datenbank einträgt (z.B. mit phpMyAdmin, Tabelle database_version) klappt das ganze. Oder eben den patch entsprechend anpassen.


    LG
    Bernd