commerce:SEO 2.0.8 weiße Seite nach Umzug

  • Hallo, leider konnte ich im Forum für Version 2.0 kein Beitrag erstellen... Folgendes Probem haben wir. Nach einem Serverumzug, kann man den Shop aufrufen und statische Seiten anschauen (z.B. Startseite, Produkte etc.). Allerdings geht nichts wo eine Aktion stattfindet (z.B. Produkt in den Warenkorb, Loggin etc.). Versucht man das, kommt man einfach auf eine leere weiße Seite ohne Inhalt. Es scheint so als könne keine Session gestartet werden? Was wir bisher gemacht haben: Alle Daten und DB auf den neuen Server geladen und die Datei/Ordnerrechte nach der Anleitung gesetzt. Die entsprechenden Pfade in der config gesetzt und natürlich die DB eingetragen. templates_c und cache geleert. Was können wir noch tun? Es ist bestimmt nur eine Kleinigkeit, vor dem Umzug hat der Shop normal funktioniert. PHP Version 5.2.17 Shopversion scheint: commerce:SEO 2.0.8 Ich habe den Shop so bekommen, kenne Ihn nicht weiter.
  • Errorlog server / host nachsehen Cache leermachen. Htaccess anpassen an den Server / host ( versuche ohne htacces , mit seourl aus und cache leer) Oft soll es mit subdomain, als [url]www.webshop[/url] oder shop.webshop sein , wen sich dort etwas geänderd hat also nur [url]http://webshop[/url]. dan vielleicht dort suchen Vielleicht einer htaccess oder setting die noch drüber etwas macht. Ist es ein CE version oder plusversion? Weil wen plus dan passen die fixpacks und updates von CE nicht und auch einiges hier aus dieser forum nicht!
  • Serverlogs lass ich nun erstellen, die kann ich ab morgen einsehen. htaccess hatte ich schon minimal angepasst, sodass sich die Webseite anzeigen lies. Entferne ich die htaccess, lässt sich außer der Startseite nichts mehr anschauen, da die Links falsch sind. Da ich keinen Zugang zum Backend habe sondern nur direkt zur DB, bräuchte ich mal die Namen der entsprechenden Tabellen zum deaktivieren. Ich hatte schon mal zum testen "MODULE_COMMERCE_SEO_INDEX_STATUS" auf false gesetzt, änderte aber nichts. Die Domain vom Shop hat sich nicht geändert. Es ist die CE Version (denke ich? oder worann kann ich das prüfen?)
  • Wenn du vermutest dass die Session nicht gestartet werden kann, könntest du entweder nach dem ALTEN sessionspeicherpfad in der DB suchen und durch den neuen ersetzen, wenn du den nichtmehr weißt mal versuchen, ob es klappt wenn du den Sessionspeicherort auf die DB änderst, letzte oder vorletzte Zeile in den includes/configure.php dateien , dort steht ein kommentar drin als beispiel wie es auszusehen hat.
  • Leider bin ich immernoch nicht weiter. Es scheint schon richtung Session zu gehen, könnte aber auch ein Problem mit der .htaccess sein. Das verschiedenen Regeln dort den Zugriff verhindern. Wie kann ich denn über die DB mal alles deaktivieren was mit mode_rewrite bzw. htaccess zu tun hat, sodass SEO-freundliche URLs deaktiviert sind und ich ohne htaccess teste kann?
  • Link? [QUOTE]Oft soll es mit subdomain, als [url]www.webshop[/url] oder shop.webshop sein , wen sich dort etwas geänderd hat also nur [url]http://webshop[/url]. dan vielleicht dort suchen Vielleicht einer htaccess oder setting die noch drüber etwas macht.[/QUOTE] Und [QUOTE]Errorlog server / host nachsehen[/QUOTE] was ist dort drin?
  • Ok also hier mal der Link zum Shop: [url]www.hivheimtests.de[/url] Einfach mal den Login versuchen (z.B. ohne Daten), oder etwas in den Warenkorb tun. Es werden leider keine Fehler abgelegt, obwohl aktiviert. Wenn ich den Installer aufrufe (das habe ich nur mal zum überprüfen der Einstellungen, dann gibs den folgenden Fehlereintrag: /kunden/.../installer/includes/application.php on line 83 [18-Mar-2013 15:30:06] PHP Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at
  • Installer lauft nur mit leeres configure, ob die fehler nur dort von ist weis ich nicht aus den Kopf. Session steht unter in den Configure's.php's also den endkunden in /includes/ den admin in admin/includes/ Am ende dort den Sessions so machen wie Mario gesagt hat also aufs DB (mysql setzen) Aus den Plus forum sollte ich eigentlich nicht machen hoffe COMSEO ist OK? ( nicht alles ist in den CE oder den v2.0.x drin !!! ) [QUOTE][B][/B][COLOR='#FF0000']Oja ganz wichtig den htaccess mit nur guten editor wie notepadd++ editen und kein extra leerzeichen irgendwo in den rewrite regeln selbst die dort nicht sein mussen [/COLOR] 500 error sehe htaccess und versuche dort die sachen mit.. so zu setzen oder Komentieren oder Auskomentieren. [QUOTE] Dieser geht bei einer Server hier auf 500 error wen nicht auskomentiert # Increase cookie security # # php_value session.cookie_httponly true #[/QUOTE] Mit folgende einstellungen auch probieren mal setzten oder auskomentieren. [QUOTE] # Port Scanner RewriteCond %{HTTP_USER_AGENT} ^w00tw00t.at.ISC.SANS.DFind RewriteRule ^.*$ 403.php [L] #Options -Indexes #Options +FollowSymlinks # Options +SymLinksIfOwnerMatch RewriteBase /[/QUOTE] Weiter in Admin backend den caches nicht einschalten zum test, cache leermachen und browser neustart und F5 Den Configure.php auch in Admin/inlcudes den richtige Rechte setzen, wen wie hier mal nicht auf 444 aber wegen fehler auf 000 gesetz komt man auch nicht in admin ;) Den configure,php am Ende wen sessions in Admin Backendsetting in datenbank dan [QUOTE]define('STORE_SESSIONS', '[B]mysql'[/B]); // frei lassen '' fuer Standard oder zu 'mysql' aendern[/QUOTE] Wen SSL dan richtige SSL nehmen kein proxy, und oft braucht man einer subdomain wie [B]www. oder shop.[/B] weil etwas mit sessions daneben gehen könnte wen nicht wegen Server einstellungen. Den Richtige einstelungen machen/setzen beim SEOurl in Admin backend und auch wirklich durchlaufen/indexieren lassen! Datei mit einer wirkliche UTF8 ohne Bom edit ( Editor wie Notepad++ mit compare plugin auch zum vergleichen von Dateien/versionen ganz einfach) und Speichern wie den german.php eigentlich alle, anders auch probs. Mit Smarty3 aufpassen mit Zeichen die nicht erlaubt sind wie zum beispiel in de lang-sprach.conf keiner [B]/* ---[/B][/QUOTE] [B]Hmm sehe auch alles nach ob es wirklich UTF8 ist (/zugelassen und und) also Datenbank, PHP (ini settings) und HTML, auch den test von den einzele Datei, weil wen leeres ist zeichensatz hier kein utf8, ok kan sein dass wirklich nicht druber komt aber...[/B]
  • Vielen Dank, habe alles probiert, leider keinerlei Änderung. Ich habe auch mal eine htaccess aus der aktuellen Version getestet, damit geht es auch nicht (kein Login, kein Artikel in Warenkorb). Es geht ja nicht mal ohne htaccess, dann kann ich zwar kein Produkt aufrufen, weil die Weiterleitung nicht klappt, aber die Loginseite kann ich ja aufrufen, der Login geht aber auch dann nicht. Echt schlimm solche Fehler ohne Ansatz...
  • [QUOTE] versuche mal auf zu rufen die domain.de/admin/ [/QUOTE] Da werde ich nach einer Authentifizierung gefragt. Dafür habe ich gerade gar keine Daten parat, bin nicht sicher wo das her kommt. Aus der htaccess wohl nicht.
  • Nein aber sollte in datenbank stehen, in jedenfall den mailadres den admin kunden, dort dan die richtige einlog, wen dass mailadres da ist aber kein ( verschlusseltes pass) dan mit den mailadres ( dafür sorgen dass die auch bei dir oder bekante ankomt) passwort vergessen funktion vielleicht mall versuchen
  • Meist oft komt pasowrt nicht wirklich mit also wen Du den Zugang habt zum mailadres dan neues passwort anfragen funktion benutzen. Wen dan einloggen klapt: Admin backend Hifsprogramme seourl abschalten, cache in den Konfigs alles aus, und cache dort leermachen. Sessions in configure.php's aufs [B]mysql [/B]!!!
  • [QUOTE]Sessions in configure.php's aufs mysql !!! [/QUOTE] Ist so eingestellt, war es von Anfang an. Passwort kann ich nicht neu anfordern, weil mir das Captcha dort nicht angezeigt wird und ich somit nicht weiterkomme.
  • Problem ist aber eigentlich wen es den free version ist, brauchst Du nur wen es die gibt den Daten aus den Kunden, Bestellungen und Produkten, ( backup und einstellungen wen die noch wichtig sindTemplate/ist aber ziemlich different die css) und dan besser den Free v2.3 downloaden, Dan sind so einiges ein probs behoben ( auch sicherheit und onebutton gesetz, und mehr funktionen und und) Neuinstall machen ( vorher den alte sichern) also auch den Datenbank. mit neue an zu legen Datenbank. Wen das geht ist in jedenfall dein hoster/ space mit einstellungen geeignet ;) Wichtiges ist dan mittels suchen ins Forum aus den Datenbank ( pass auf stanard deutsches langid geht von 1 auf 2) den rest machen ( phpmyadmin oder so)
  • Eine neuinstallation der aktuellen Version und integration der alten Daten kann ich probieren. Allerdings wurde hier nichts an der Datenbankstruktur geänder, lässt sich das so einfach migrieren? Eine andere Sache noch, wenn ich in der configure.php define('COMMERCE_SEO_INSTALLED', 'true'); auf "false" setzen und über /installer den Installationsprozess aufrufe, meldet er das alles ok ist und die Konfigurationen und Ordnerrecht stimmen. Gehe ich dann auf installation fortsetzen, kommt die folgende Ausgabe: Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /kunden/.../inc/xtc_image.inc.php:183) in /kunden/.../installer/includes/application.php on line 83 Warning: Cannot modify header information - headers already sent by (output started at /kunden/.../inc/xtc_image.inc.php:183) in /kunden/.../inc/xtc_redirect.inc.php on line 53
  • Das ist weil den tabelle da sind und so weiter dafür besser ein neu Datenbank anlegen die leer ist. Aber von alt nach neu einfach hier ins forum suchen update v2.2 oder update v2.3 , tabellen von datenbank nur export import geht also nicht! Man soll es in ein zwischendatenbnk, zum aufbereitung / änderung /update machen, dort nur den Kunden / Bestellungen / Artikel teilen ( fertig machen für den neues heist meist wichtig den langid ändern) den rest muss man in neues Konfigurieren ( also alles von Shopsystem und layout selbst) Zu viel ist anders, ! Aber weitermachen mit ein altes wofür keiner download von updates mehr gibt auch kein support ist nicht so gut, weil sicherheits update und onebutton gesetz hat man dan nicht zum beispiel!