500 Internal Server Error

  • Hallo,


    hab grad die Version SEO v2.3.1 CE installiert und komm nicht auf den Shop wegen
    Fehler 500 Internal Server error
    Provider = 1 und 1
    anscheinend (nachdem ich nun alle alten Beiträge im Forum durch habe) gibts da mit der .htaccess Probleme
    ist das bei der neuen Version von SEO v2.3.1 CE immer noch der Fall?
    habe bereits mehrere Sachen in der .htaccess auskommentiert und einkommentiert geht aber nicht


    Liegt denn dieses Problem nun eigentlich bei 1 und 1?


    Ich bitte hilfesuchend um eine Antwort, da ich von der Shop-Technik sehr wenig verstehe :-(


    bin auch total verunsichert, ob denn diese alten Beiträge hier im Forum für meine Situation zutreffen.


    danke schon mal für eure Hilfe


    Ciao
    Angelika vom Perlenkaufladen

  • hoi,


    das "problem" ist das jeder hoster gewisse module, etc. nicht zwingend freigeschaltet hat. manche haben php als cgi laufen, manche nicht, mache haben, manche haben php version x, manche version y, etc. ...diese möglichkeiten können nun auch noch je nach gebuchtem paket differieren... von daher ist die .htaccess so allgemeingültig wie möglich formuliert, und auch mit kleineren änderungen (fast) überall einsetztbar (ausgenommen sind natürlich hoster wie "getunteKaffeemaschine24.com" aus bagaludistan /ironie:OFF) ;)


    durchsuch bitte das forum mal nach dieser problematik, sie ist hier schön des öfteren besprochen worden. kostja hat dir schon einen ersten anhaltspunkt geliefert, aber es gibt noch mehr :)


    greetz, me

    <p>C lets you shoot in your feet, C++ allows you to reuse the bullet.</p>
    <p><strong>Thats <span style="color: #b22222">NO BUGS</span>, thats <span style="color: #008000">FEATURES</span>!
    </strong></p>
    <p><strong></strong>[LEFT]<strong><span style="color: green">Die Suchfunktion steht nicht unter Naturschutz, und darf getrost benutzt werden.</span></strong><br>[/LEFT]<br>[INDENT=4] <img src="http://support.commerce-seo.de/image.php?type=sigpic&amp;amp;userid=64&amp;amp;dateline=1309425110"><br>[/INDENT]</p>

  • Bitte jede die so etwas hat, hier zu posten und auch wie behoben wen dieser noch nicht hier steht.


    Weiter Kostja hat meist recht! ;)


    Oja ganz wichtig den htaccess mit nur guten editor wie notepadd++ editen und kein extra leerzeichen irgendwo in den rewrite regeln selbst die dort nicht sein mussen


    500 error sehe htaccess und versuche dort die sachen mit.. so zu setzen oder Komentieren oder Auskomentieren.


    Zitat


    Dieser geht bei einer Server hier auf 500 error wen nicht auskomentiert
    # Increase cookie security
    # <IfModule php5_module>
    # php_value session.cookie_httponly true
    #</IfModule>


    Mit folgende einstellungen auch probieren mal setzten oder auskomentieren.


    Weiter in Admin backend den caches nicht einschalten zum test, cache leermachen und browser neustart und F5


    Den Configure.php auch in Admin/inlcudes den richtige Rechte setzen, wen wie hier mal nicht auf 444 aber wegen fehler auf 000 gesetz komt man auch nicht in admin ;)


    Den configure,php am Ende wen sessions in Admin Backendsetting in datenbank dan

    Zitat

    define('STORE_SESSIONS', 'mysql'); // frei lassen '' fuer Standard oder zu 'mysql' aendern


    Wen SSL dan richtige SSL nehmen kein proxy, und oft braucht man einer subdomain wie www. oder shop. weil etwas mit sessions daneben gehen könnte wen nicht wegen Server einstellungen.



    Den Richtige einstelungen machen/setzen beim SEOurl in Admin backend und auch wirklich durchlaufen/indexieren lassen!


    Datei mit einer wirkliche UTF8 ohne Bom edit ( Editor wie Notepad++ mit compare plugin auch zum vergleichen von Dateien/versionen ganz einfach) und Speichern wie den german.php eigentlich alle, anders auch probs.
    Mit Smarty3 aufpassen mit Zeichen die nicht erlaubt sind wie zum beispiel in de lang-sprach.conf keiner /* ---



    Für suche in den komplette Dateien und ordner passt dass Program
    "Agent Ransack"


    Bearbeiten und BACKUP MYSQL Datenbanken, dafür gibt es "PHPMYADMIN" und/oder "MYSQL dumper"[/B]

  • Vielen Dank für eure Hilfe! :)


    habs auch hingekriegt
    für mich war sehr hilfreich der Link zu http://blog.anypoint.de/cseo-2…und-die-htaccess-von-cseo
    für mich als Laie genau richtig
    hab mir auch ganz brav das Notepad++ installiert


    nur so zur Info:
    Installation SEO v2.3.1
    Provider 1 und 1
    diese Sachen hab ich in der .htaccess anpasst


    Zeile 138: #Options -Indexes
    Zeile 141: #Options +FollowSymlinks
    Zeile 174: #Options + SymLinksIfOwnerMatch
    Zeile 192: RewriteBase /


    Vielen Dank nochmal
    schön dass es hier auch Hilfe für "Dummies" gibt :-)


    liebe Grüße
    Angelika