Anzeige von Sonderzeichen bei erstem Seitenaufruf

  • Hallo Forum,


    wie bereits in diesem Thema beschrieben (http://support.commerce-seo.de…n?highlight=sonderzeichen) habe ich ebenfalls beim ersten Seitenaufruf die Anzeige der Sonderzeichen.


    Der Shop wird direkt durch eine Subdomain angesprochen, liegt also in einem Unterverzeichnis auf dem FTP aber die URL ist direkt darauf verwiesen.


    Sobald die Seite einmal aktualisiert wird wird die Seite korrekt angezeigt.
    Auch nach dem Wechsel zu einer anderen Seite zum Beispiel Google und erneutem Aufruf der Seite wird sie korrekt aufgebaut.
    Erst wenn der Browser geschlossen und neu geöffnet wird taucht der Fehler wieder auf.


    Leider ist im genannten Thema kein Lösungsansatz vorhanden. Die Englische Sprache wurde aus dem Shop über den Admin entfernt, gehostet wird über Domain Factory.


    Hat dazu jemand eine Lösung


    Hier einmal zur Verdeutlichung der Angezeigte Fehler:


    ---
    �x��Y[s�6~^��? |�e֒��Mlu��u3IO�lf���@$$'�.��{�7��o�c���H�n�f3S�X$��s���Ƚ�/߽x���CV�����ڣ+S\���\$aD���K�9� n���I�g�݄�h��`pkk�+���:)L��̟q+Xf�Ka3����;�lz�>�i.��kvhg��l���t0�y0f?��� �E'�0?-M{ʙ�LX�.L� 9/�sW|�;�h4:1���hǸ�ى��2nxk�}!X�r���t��i��J��2ʣ>�#����WS%3�����?�$��}�S�}�l4'��u54v>R�΍����;C ���`ʝș��:��C=�Z�����ʳ{�}r�v��5T�,��{�Fp�r+ �7���aG�� �(��ds-?���%���7��Jό]r�N ̌����:���A�{ �׊�`�To���K��̃ӽ�I�Oh� r ���/�ݢ�^ �j?q�B W�VX1�Oj�b?��7^H%F/�B��2�p�97,�2a���^�{L��-�!|?)��$2r�6�� ��6ƭ,}w�'~��hœ�6��ɥ�A���(�����7���+1��, �J-�zo'X��8q!.Ό�]LJ�z��x����mc�m�K̝�q]o��0qlM^-�t��^V?��� �� ���L؜��w�-��\()��!S���f?��Е�o�y\N���F(9\�|� T"�*z�yA<��/����v���k�-�A���\QT`G��H8� �d��9wA������VYAN:������* #�VX.UN"���B%��)���;��y'�Ht;�@ģh^�0JC� ��m|���*2ه)��+��Ћ�m� �0{�,�+_�O����`=��O���fH�N����YP�҃�e'��\j��R�� cz 3 �3@�����r�.Q��l`CU�;2������ !�(�Vˇ�amF�k��w3]�g�9����e]$:���^��RG8��5�� �,QY��#���ϗ S����� �N���Kn���#�N�8���J��'Q��k����� f���C�Լ@i}VyF��3�)7:ıu��Sb� ҿ&�H���a��5o���:`� �+,3�.��2O$uY�����? [7��&�k����I��.�yX�ˀǔ|��i���&�}� ��TUPK���B�a$ۿ{�>�<��/����LV��+�H�|h%N�� ��s员֞��}��#�����8�'��������V�����ڸ���J�N*��?������y��x�BZ�E�$�����Q?� лHM�?#Z�� jV����hg�.�Q����m������ӝd��yj��(ԆN�a*t�/�6$Ub���So�ͬ7�pY/3%�~G�IK��3~��q�LB�� � rӒM&]`�ǭD�[t@#V�\��P�G��w�6�+f'���_��׹���쮑����c�;��7���3Cp�)>^J|������l.�J�Ͽ�f�R�� ���CI�L��#Z�(�$�����Jv^����p�j4m�z��-L'�Az������|^�:�;������{�=�v��W!{�F����NU-�s[��ۯG�pZ܃Ԁ�clI�k��|�2bz��!^]ʵ��,��^��%�� _J�����L�W� ��I� �y�7�Nؠy �t^4.��>��}T��l��8u}���<���!Ī�϶�46����M��>��á��)���4+6ݾ�j�4����nn[f��Z'��k6zVY�K�v����� kI3)�ά}ڔU.VoH��;�ڧ?�BL��{-D;@-Dӭ�N�kV�*�5ۛ��M�v�?�=`��$܊l�-p�&]�2������Йy�rG}dC�V�,����疶5����D3c��4���`3��x�D����S�4pʏM)a*�>�BHD)���jk� W;�V�u����|8�4T���M8;�|�/A8��BQ�`���W��Y�c+O�we���6|�b/��h�ӕ��"������&�}�8";8���T���ⴉ�W˒�b��"��PF�H��n|��H�St���&?b[[͜E�e����mTI�����k>�Vom�_f;���5�7f�%0��if�P�z����J�Q29h��QáX�&�|Ћ_��ѵ�v���K�Q�����?%�L) ---


    Was mir gerade noch aufgefallen ist, es ist niemals der gleiche Zeichencode der dargestellt wird.

  • hmmm Einstellungen die nicht passen aufeinander wie Server und oder htaccess, zum beispiel.


    Vielleicht htaccess kurz umbenennen, was passiert dan?
    Seo url soll dan vorab naturlich abgeschalted sein.


    So etwas gesehen aber dan wen sicherheitseinstellungen Server mittels htaccess settings versucht zu ändern, was dan nicht wirklich "erlaubt" war, Konflikt mit aber weis nicht ob es dass gleiche ist und ist lange her.

  • Versuch ein ganz normale index.html


    danach einer index.php mit etwas einfaches.


    Jedenfall mit einstellungen und code utf8


    Also meine etwas hin zu setzen auserhalb den COMSEO Datei aber in den Verzeichnis wo dies steht

  • Ich hab einfach mal eine leere index.html gemacht, dachte nicht das es funktioniert und tat es auch nicht.
    Jotest tut mir echt leid aber ich hab gerade keine Ahnung was du von mir möchtest :D


    Mario_b, mag sein aber was tu ich dagegen


  • Jotest tut mir echt leid aber ich hab gerade keine Ahnung was du von mir möchtest :D


    ;) nichts


    Index.html mit kleiner text ?!


    Dieser mit komplettes URl also

    Zitat

    deindomain.de/index.html

    wen in verzeichnis dieser auch mitgeben.
    Mit www und ohne aufrufen. ( dieser gemacht ? )


    Wen dies schon nicht geht nachsehen ob nicht irgendwo in einer einstellung doch einer htaccess oder ähnliche settings in server konfig / deiner konfig gibt.
    Meist einer Verzeichnis höher oder, was man mit ftp oft sehen kan.


    Sorry subdomain aufrufen naturlich mit den index.html in browser!

    Zitat

    sub.deindomain.de/index.html

    Dan noch zum testen den Verzeichnis mit hauptdomain davor

    Zitat

    deindomain.de/verzeichnissub/index.html



    Deiner Subdomain ist ein virtueles mit also Speicher von Datei ins Verzeichnis von Hauptdomain, so etwas ist meist auf server eingesteld und oder in einer extra htaccess, wo dass Konflikt liegen könnte

  • So ich hab von einer anderen Domain via index.html verlinkt.
    Hab den Shop in ein anderes Verzeichnis installiert und per domain.de/shop aufgerufen.
    Gleiches ergebnis.
    Was mich wundert ist jedoch, dass obwohl ich angegeben habe das die Beispieldatenbank installiert werden soll ist das Demoprodukt nicht vorhanden.
    evtl. Fehler in der Datenbank struktur

  • DemoProdukt glaube dass ist beim v22 nicht drin, vielleicht wegen den alte Sprachid , sagt aber weiter nichts über dein problem


    Versteh nicht ob ja oder nein einer index.html mit nur text ja oder nein lauft.

    Zitat

    So ich hab von einer anderen Domain via index.html verlinkt.


    Wei auch in deiner link zum andere beitrag, normal ist etwas mit einer htaccess oder ähnliches ( server / deinspace einstellungen dort) nicht gut und die kan naturlich in einer übergeordnete Verzeichnis liegen, oder übergeordnet greifen.


    Wei den andere Konflikt mit den htacces von gambio war in den hauptverzeichnis, kan auch so etwas hier sein.


    Alles mus UTF8 CODEd sein , also den php ( auch den php einstellungen die man vielleicht hard in den php.ini stehen hat, html und Datenbank, bei Gambio und co ist dies zum bespiel nicht den fall!!



    Ist für mich naturlich alles so nur vermutungen weil kein links und und da sind, von den hauptdomain, sub domain .

  • OK wordpress hat auch so einiges an htaccess und co ( wie bei Joomla ein benutzer auch so etwas gehabt hat)
    Konflikt kan man da haben mit den haupt htaccess, weiter gibt es viele unterschieden und problemen mit den verschiedene hoster wegen ja oder nein virtueles subdomain, ( in unterverzeichnis von Hauptdomain den Datei) und reales Subdomain mit eigen space.


    Ist halt so ( zu viele config unterschieden)und muss man beim hoster nachfragen welche htaccess settings greifen und oder konfliktieren.


    Weiter http://autoteile-onkel.de/shop/ also ohne www geht auf den hauptdomain zuruck, also weiterleitungen stehen auch nicht wirklich richtig

  • Denke wen Du die htaccess von shop richtig einstellt und den seourl auch, weiter dies indexieren lasst, es ja oder nein lauft oder mehr probleme kommen die dan aber vielleicht hilfen können die richtige settings aus zu finden bei deiner Konfig / hoster



    CommerceSEo ist UTF8 Ohne BOM also auch wen man etwas editiert den richtige editor wie notepad++ benutzen

  • Ich hatte den Fehler ja auch als der Shop in seinem eigenen Verzeichnis lag und über eine Subdomain aufgerufen wird.
    Ich verstehe nicht wie es die htaccess sein kann wenn der Fehler auch auftritt wenn ich diese lösche.
    Das ändert ja nichts am Fehler.


    Evtl. sollte ich einfach eine andere Software nutzen oder die ganze Idee komplett lassen. Son mist.

  • Ich hatte den Fehler ja auch als der Shop in seinem eigenen Verzeichnis lag und über eine Subdomain aufgerufen wird.
    Ich verstehe nicht wie es die htaccess sein kann wenn der Fehler auch auftritt wenn ich diese lösche.
    Das ändert ja nichts am Fehler.


    Evtl. sollte ich einfach eine andere Software nutzen oder die ganze Idee komplett lassen. Son mist.



    Liegt hier nicht an comseo aber deiner übrige einstellungen!
    Alles muss ja halt passen und Richtig gesetzt werden, auch immer den htaccess die bei ein Paket ist als ein Example betrachten die auf den richtige settings seiner Server / Webspace angepasst werden MUSS



    Wie gesagt Du benuzt kein wirklich eigenständiges Subdomain mit eigener webspace, also greifen hier vielleicht den Domain einstellungen von Hauptdomain.


    Den htaccess die benuzt werd für den wordpress, und oder domainspace ist hier zusammen mit vielleicht noch weiter an einstellungen verantwortlich.
    Habe es ja vorhin mal gesagt wie user mit Joomla auf hauptdomain, und oder ander shop wie Gambio und co.


    Sehe auch den link aus deiner erste beitrag ( dort waren es gambio settings), dan sind ja halt andere einstellungen gemacht worden auf den Hauptdomain / Webspace, und auch aktiv die Konflikte geben können, wen es weiter nicht richtig gemacht werdet.


    Dafür wen keinn kentnis dein Hoster und oder Service partner von comseo fragen

  • übrigens nachweislich so dass es ein andere htaccess und weiterleitung greift dan den von comseo


    http://www.autoteile-onkel.de/shop/y sehe was dan kommt!


    Dein Webspace worauf Du den INStall macht ist halt den Wordpress teil sehe

    Zitat

    kunden/331876_45475/webseiten/Autoteile-Onkel.de/wordpress


    Dort lauft wahrscheinlich auch nicht 123 gambio



    Dieser install

    Zitat

    kunden/331876_45475/webseiten/Autoteile-Onkel.de/wordpress

    rufst Du selbe immer hier auf weil vorab dieser Domain den Weiterleitung / htaccess von Wordpress benutzt werdet.


    Um sauber zu gehen, muss dieser subdomain / verzeichniss ertmals aus den Wordpress (htaccess) webspace heraus geholt werden

  • Ich danke dir für die Hilfe jotest.
    Der Fehler bestand auch als ich es nicht im Wordpress Verzeichnis installiert hatte.
    Hab Seocommerce nun gelöscht und in das selbe Verzeichnis Gambio installiert und siehe da es funktioniert, hier auch ohne www

  • ISt ja andere htaccess und seourl ( und kein utf8 soweit ich weis) vielleicht kein Konflikt.
    Wie gesagt den htaccess ist einer example und muss man richtig selbe anpassen auf seiner Konfig


    Kan noch kommen wen sumaurl laufen soll also testen