CAPTCHA-Fehler bei "Fragen zum Produkt"

  • moin,moin,
    habe die aktuelle Version: "commerce:SEO 2.1.2.8 Plus" unter der Domain webshop.coderx.de am laufen, leider verurachst er Fehler mit den Captcha.


    Möchte ein Kunden über den Artikel "Fragen zum Prdoukt" stellen, so wird dieser Kunden aufgefordert ein Captcha-Coder zu hinterlegen.
    Statt den Captch-Coder erhalte ich nur das Wort "Captcha"
    Hier ein passender Link dazu: http://webshop.coderx.de/de/URL-Alias-Produkt-1.html


    Das Rechenzrtrum hat die Servereinstellungen überprüft und es ist alles in Ordnung, nur das das Script etwas nicht findet, lt. der log.Datei

  • Achso, das ist die Antwort vom Rechenzentrum:


    Hallo Herr Gerdes,


    offenbar liegt hier ein Programmierfehler vor. Wenn die Seite die das Captcha erstellen soll manuell geladen wird, http://webshop.coderx.de/captcha_math_ask.php , gibt es einen Fehler:
    "Die Grafik ... kann nicht angezeigt werden, weil sie Fehler enthält."


    Kontaktieren Sie diesbezüglich bitte den Hersteller der Software.



    die "libpng" ist installiert und funktioniert, aber Fehler bleibt

  • hoi,


    du solltest mal deine pfade für die captchas in den configure-dateien (SuFu nutzen!), UND die schreibrechte von dem captcha verzeichnis überprüfen!


    zu dem zweiten post, zwecks programmierfehler: lass dir von den friseuren nichts erzählen! :mad:
    wird das script direkt aufgerufen KANN es nicht funktionieren! warum? ganz einfach, es wird ein bild erzeugt (und demzufolge auch der entsprechende mime gesendet), welches über das entsprechende html-tag eingebunden wird. rufen wir das script aber nun im browser direkt auf, versucht der browser was? richtig, er versucht textuell zu parsen und den mime von image/png auf text/html zu setzen, woraus sich logischerweise was ergibt? richtig, ein fehler! -.-


    greetz, me

    <p>C lets you shoot in your feet, C++ allows you to reuse the bullet.</p>
    <p><strong>Thats <span style="color: #b22222">NO BUGS</span>, thats <span style="color: #008000">FEATURES</span>!
    </strong></p>
    <p><strong></strong>[LEFT]<strong><span style="color: green">Die Suchfunktion steht nicht unter Naturschutz, und darf getrost benutzt werden.</span></strong><br>[/LEFT]<br>[INDENT=4] <img src="http://support.commerce-seo.de/image.php?type=sigpic&amp;amp;userid=64&amp;amp;dateline=1309425110"><br>[/INDENT]</p>

  • Darauf bezogen:
    du solltest mal deine pfade für die captchas in den configure-dateien (SuFu nutzen!), UND die schreibrechte von dem captcha verzeichnis überprüfen!


    Schreibrechte für das Verzeichnis captcha ist 0777 sind vorhanden.
    Es werden auch entspr. Dateien (Captcha-Grafiken) dort angelegt, aber nicht angezeigt.



    config-Datei -> include/configure.php ist in Ordnung
    -define('DIR_FS_CAPTCHA_MAKE', DIR_FS_CATALOG . 'captchas');
    - define('DIR_FS_CAPTCHA_CHECK', DIR_FS_CATALOG . 'captchas/');



    Habe nun ein Mustershop der aktuellen Version installiert, dort funktioniert es. Also hat Rechenzentrum recht ;)




    Wer kann mir dort weiterhelfen??????