Bestellbestätigung und Kontaktformular Emails kommen nicht

  • Hallo Forum, Wenn ein Kunde bestellt erhält er eine Emailbestätigung seiner Bestellung. Ich als Admin erhalte leider keine Email über die Bestellung. Wenn der Kunde ein Kundenkonto anlegt funktioniert es - sowohl Kunde als auch Admin erhalten eine Email über Eröffnung des Kontos. Sendet der Kunde über das Kontaktformular eine Anfrage, erhalte ich als Admin keine Email. Ich habe die SEO V1.1.0 Community installiert. Der Server ist bei Goneo. Vorgehensweise bei der Installation: Webspace gekauft bei Goneo. Danach Shop unter Goneo-URL installiert. Danach DOMAIN von United Domains an Goneo übertragen und Pfade in den Config-PHP´s abgeändert. Könnte es vielleicht damit zusammen hängen? Über jede Anregung wäre ich sehr dankbar! Viele Grüße Whyatt [url]www.brodit-profi.de[/url]
  • Ich versuche mal den Anschluss zu bekommen. Die Domain ist bei einem externen Hoster, der Shop bei Gone? Dass sollte generell auch kein Problem sein, Du musst nur darauf achten, dass auch der MX Eintrag stimmt: z.B. mail.deinedomain.de Alternativ kannst Du Dir auch die Bestellung in Kopie senden unter Admin > E-Mail Konfig. ganz unten. Irgendwas passt da mit den Maileinstellungen nicht auf Deinem Server, eventuell etwas zu restriktiv eingestellt.

    Wir geben nur Anregungen und Hilfestellung auf Basis unserer Erfahrung, keine Rechtshilfe!
    \m/('_')\m/

  • danke für die antwort. ich erkäre es noch einmal genauer: problem ist ja, dass ich als admin keine email über die bestellungen erhalte. auch wenn jemand über das kontaktformular eine anfrage sendet kommt keine mail bei mir an. bezüglich der installation: ich habe den webspace bei goneo gekauft und den zugang erhalten. die url unter der mein webspace dann direkt nach erhalt der zugangsdaten erreichbar war, war irgendetwas wie [url]www.12345webtest.goneo.de[/url]. unter dieser adresse habe ich den shop installiert. 4 tage später war dann der domainumzug fertig. das heißt fortan war der shop unter der unten angegebenen adresse erreichbar. (die domain war bei united domains und ist dann eben zu goneo umgezogen). in den config-dateien steht ja der pfad zum shop drin. dort habe ich die alte adresse (12345webtest.goneo.de) gegen brodit-profi.de ausgetauscht, damit die urls immer schön mit brodit-profi.de gebildet werden, wenn man im shop herum klickt. bei goneo habe ich eine emailadresse eingerichtet info[at]brodit-profi.de. wenn man eine email an diese adresse sendet, kommt die email bei mir an. ebenso bekomme ich als admin eine email, wenn sich ein kunde neu registriert. deshalb denke ich nicht, dass es mit der emaileinstellung bei goneo zu tun hat... die kopie in der admin habe ich schon probiert. leider ohne erfolg. es kommt keine mail bei mir an. Vielen Dank noch einmal fürs helfen. grüße whyatt
  • hallo nochmal ;-) leider bekomme ich immer noch keine emails bei bestellungen oder wenn jemand über das kontaktformular eine email sendet. beim admin habe ich jetzt die email auf die email der domain umgestellt - leider immer noch ohne erfolg. hast du noch eine idee? danke viele grüße whyatt
  • Also am besten mal Deinen Hoster fragen. Ich hatte mal ein ähnliches Problem nach einem Update von Plesk. Da gingen die Mails auch nicht mehr raus. Läuft Dein Webspace auf Plesk? Umgehungslösung: Im Admin > E-Mail Einstellung mal auf "SMTP" umstellen und einen gültigen Zugang eingeben in den nächsten Zeilen.

    Wir geben nur Anregungen und Hilfestellung auf Basis unserer Erfahrung, keine Rechtshilfe!
    \m/('_')\m/

  • hi, das seltsame ist dass die emails aus dem shop ja teilweise funktionieren: wenn sich ein kunde neu anmeldet, bekommt er und ich eine email über die neuanmeldung wenn ich in der admin einen kunden auswähle und dann auf email an kunden senden gehe, kommt die email beim kunden an. wenn ein kunde bestellt, erhält er die bestätigung - ich aber nicht wenn ein kunde das kontaktformular nutzt, bekomme ich nichts. das heißt doch, dass die einstellungen eigentlich richtig sein müssten und eine verbindung zum server besteht... oder? vielen dank! bin kurz vorm verzweifeln. habe auch schon alle emaileinstellungen durchgetestet - sendmail, smtp, mail grüße whyatt
  • welche email Adressen verwendest du im shop? Denn bei goneo funktioniert das nur mit den Mailadressen die auch bei goneo angelegt sind, und nur Diese dürfen im Shop benutzt werden wie [email]zb.info@deineDomain.de[/email]. Selbst eine weiterleitung auf eine andere Adresse wie [email]xy@gmx.de[/email] funktioniert nicht! Betreue selber einen Shop bei goneo!
  • hallo widwolle, wäre klasse wenn du mir da helfen könntest. um konkret zu werden habe ich mal die emaileinstellungen kopiert: [URL='http://www.brodit-profi.de/images/content/email.jpg']http://www.brodit-profi.de/images/content/email.jpg[/URL] als smtp passwort habe ich das bei goneo bei der emailadresse hinterlegte passwort eingetragen. die domain heißt brodit-profi.de ich habe schon über 10 stunden verbraten mit trial & error und alles mögliche ausprobiert... ich bekomme es einfah nicht hin. muss man vielleicht in einer php datei noch etwas ändern? @widwolle: wie lauten denn deine einstellungen? verzweifelte grüße whyatt
  • Sorry das ich mich erst jetzt melde Hier meine Einstellungen.habe bei goneo 3 emails angelegt info,bestellung und kontaktqdomein.de und alle mit dem selben Passwort. 1. [url]http://www.bilder-space.de/show.php?file=30.052ibJyHkNOpHbiyb.jpg[/url] 2. [url]http://www.bilder-space.de/show.php?file=30.05mTCLnGWrkgSPxqx.jpg[/url] 3. [url]http://www.bilder-space.de/show.php?file=30.05RttdMtXagCgk2iS.jpg[/url] und Register mein Shop die 2 emails auch noch ändern auf [email]info@xxx.de[/email], so das nur noch Emailadressen von goneo im Shop sind. als smtp Adresse habe ich die [email]info@xxx.de[/email] mit dem dazugehörigen Passwort genommen. Allles funktioniert soweit Registrierungsmais an Admin und Kunden, Bestellmails an Admin und Kunden, und aus aus dem Admin Mails an die Kunden versenden. Wohl muß ich dabei sagen das es noch probleme über eine Anfrage über das Kontaktformular gibt, da kommen keine Anfragen durch von mailadressen (t-online,gmx) sondern auch wieder nur mailadressen mit @domainnamen.de. Mit der Einstellung auf SMTP ging über das Kontaktformular garnichts, drum habe ich auf sendmail gestellt und es funktioniert jetzt wenigstens einigermaßen. Da muß noch dran gearbeitet werden. Jedoch sonst funktioniert alles. Ich hoffe ich konnte wenigstens etwas helfen.
  • hallo widwolle, vielen dank für deine ausführliche erklärung und deine screen shots. ich habe deine einstellungen 100% kopiert und habe immer noch folgende probleme: keine admin emails bei kontaktformular, keine admin email bei bestellungen. admin email bei kundenneuregistrierung wird gesendet. wenn ich bei deinen einstellungen auf smtp umstelle und über das kontaktformular eine anfrage sende kommt die fehlermeldung "Mailer Error: SMTP Fehler: Die folgenden Empfänger sind nicht korrekt: [email]kontakt@brodit-profi.de[/email], [email]kontakt@brodit-profi.de[/email]". ich habe am donnerstag abend auch eine anfrage an goneo gesendet... mal sehen ob die noch ne idee haben. seltsam finde ich aber nach wie vor, dass die emails bei kundenregistrierung gesendet werden, bei bestellung und kontaktformular jedoch nicht. vielleicht hat da noch jemand eine idee. vielen dank schon mal für eure hilfe! grüße whyatt
  • hallo zusammen, heute kam die antwort von goneo wegen des email problems: "haben Sie den Shop auch so eingerichtet, wie es in der goneo-Hilfe beschrieben steht? Andernfalls erhalten Sie genau deswegen keine Mails. Anbei der Link: [URL='http://wiki.goneo.de/doku.php?id=emailversand_webserver']http://wiki.goneo.de/doku.php?id=emailversand_webserver[/URL] könnte sich bitte jemand den link kurz ansehen und mir sagen, ob der shop das alles so gewährleistet, wie die das wollen? herzlichen dank whyatt:confused: