B+W Payment Schnittstelle

  • Hallo


    Ich habe ein ganz nettes Modul für Kreditkartenzahlung gefunden, dass gerade für kleiner Shopbetreiber interessant ist (denke ich mal). Leider funktioniert das XTC Modul nicht korrekt.
    Wenn das integriert werden könnte würde sicherlich nicht nur ich mich darüber freuen ;-)
    Zu finden ist die XTC Version beispielsweise hier: http://www.snyware.com/downloa…rce/B_UND_W_XTC_Modul.zip
    Infos zu dem ganzen System gibt es hier: http://www.1st-payment-portal.…hp?l=de&d=1&c=de/main.htm
    Leider kenne ich mich in der Programmierung solcher Schnittstellen und im Code von commercs:SEO nicht aus. Soonst hätte ich selbst mal mein Glück robiert.
    Gibt es Dokumentationen zur Schnittstellenprogrammierung? Bzw. einen Leitfaden wo die Unterschiede zwischen XTC und Commerce:SEO hier liegen?


    LG
    Bernd

  • hallo bernd,


    wir sind in der letzten zeit davon abgekommen, support für externe bezahlmodule zu bieten. da letztlich versucht wird, die haftung bei problemen auf uns abzuwelzen (obwohl der code meist fehlerhaft ausgeliefert wurde). von daher ein klares nein zu deinem request.
    was für probleme bestehen denn mit dem modul? schon probiert das modul über den normalen checkout (nicht onepage-checkout) laufen zu lassen?


    greetz, me

    <p>C lets you shoot in your feet, C++ allows you to reuse the bullet.</p>
    <p><strong>Thats <span style="color: #b22222">NO BUGS</span>, thats <span style="color: #008000">FEATURES</span>!
    </strong></p>
    <p><strong></strong>[LEFT]<strong><span style="color: green">Die Suchfunktion steht nicht unter Naturschutz, und darf getrost benutzt werden.</span></strong><br>[/LEFT]<br>[INDENT=4] <img src="http://support.commerce-seo.de/image.php?type=sigpic&amp;amp;userid=64&amp;amp;dateline=1309425110"><br>[/INDENT]</p>

  • Hallo


    Das Problem ist, dass sobald man auf die Seite der Bank kommt eine Fehlermeldung auftaucht.
    Den One Page Checkout habe ich noch nicht getestet. Werde ich mal tun und Rückmeldung geben.
    Für das Bezahlmodul gibt es zwei Versionen. Eine für XTC 3.03 und älter und eine für 3.04 SP2.1 welche ist da angebrachter zu nutzen?
    Grüße


    Bernd

  • hoi,


    definitiv die letztere :). kann es sein das der anbieter z.zt. ein allgemeines problem mit seinem service hat, und das modul deswegen nicht funzt?


    greetz, me

    <p>C lets you shoot in your feet, C++ allows you to reuse the bullet.</p>
    <p><strong>Thats <span style="color: #b22222">NO BUGS</span>, thats <span style="color: #008000">FEATURES</span>!
    </strong></p>
    <p><strong></strong>[LEFT]<strong><span style="color: green">Die Suchfunktion steht nicht unter Naturschutz, und darf getrost benutzt werden.</span></strong><br>[/LEFT]<br>[INDENT=4] <img src="http://support.commerce-seo.de/image.php?type=sigpic&amp;amp;userid=64&amp;amp;dateline=1309425110"><br>[/INDENT]</p>

  • Hallo


    Ein allgemeines Problem gibt es so viel ich weiß nicht. Auf anderen Seiten läuft das Modul wohl problemlos. Das sind aber wohl alles (unmodifizierte) XTC Shops.
    Testen ob es mit dem Mehrseitigen Checkout funktioniert kann ich leider erst morgen.


    Bis denn ...
    Bernd

  • Hallo


    Ich habe das Modul nun mal mit dem mehrseitigen Check Out gestestet. Es funktioniert beinahe.
    Die Zahlungen kommen an und die Bestellung ist im Shop Backend sichtbar.
    Leider bekommt der Käufer nach dem er vom Bezahlgateway zurück auf die Shopseite geleitet wird folgende Fehlermeldung:


    Die Mail konnte nicht versendet werden.


    Mailer Error: Die folgende Absenderadresse ist nicht korrekt: <die Emailadresse des Kunden>


    Hat hierzu jemand einen Tipp?


    Die Emailadresse die angegeben ist ist aber durchaus korrekt.


    Das ganze läuft auf einem HOST EUROPE rechner. die sind ja ein wenig kleinlich, was das Emailversenden angeht. Daher läuft in der Installation der Emailverkehr über SMTP. Kann es sein, dass im Modul dennoch per sendmail verschickt wird?



    Liebe Grüße
    Bernd



    EDIT: Hatte was falsches geschrieben.

    2 Mal editiert, zuletzt von nMedien () aus folgendem Grund: Weitere Infos und Idee ....

  • da würd ich fast mal gucken was passiert, wenn du mit ebenjener emailadresse versuchst eine ganz normale bestellung via vorkasse o.ä. durchzuführen, könnte mir vorstellen, dass du diegleiche fehlermeldung bekommst und es garnicht mit dem modul zutun hat (kenne m.E. kein Payment modul was "von sich aus" mails versendet").

  • Treffer!
    Nur warum das so ist verstehe ich nicht.


    Ich habe nun mal mit verschiedenen Adressen getestet. Bei gmx und hotmail bekomme oich Fehler. Auch beim Vorkassenmodul. Bei anderen getesteten Adressen nicht.
    Da fürchte ich fast, dass ein Problem seitens commerce:seo vorliegt ... oder?
    Wenn ich an die gleichen Adressen aus dem Backend heraus eine Email sende werden sie verschickt. Nur nicht beim Bestellprozess.
    Die Mails werden über SMTP verschickt. Das gehört aber dan wohl eher in den Bugreport ... werde mich da mal schlau machen und gegeben falls was posten ...
    Danke schon mal.

  • hoi,


    über hosteurope kann man zb. keine mails von gmx oder google (u.a.) versenden. ich würde über einen providerwechsel nachdenken (nicht nur wegen der email-geschichte). der shop arbeitet in dem punkt allerdings korrekt. bitte durchsuch das forum mal nach dem thema, wir haben bereits eine anderweitige lösung gepostet, für kunden die nicht wechseln wollen.



    greetz, me

    <p>C lets you shoot in your feet, C++ allows you to reuse the bullet.</p>
    <p><strong>Thats <span style="color: #b22222">NO BUGS</span>, thats <span style="color: #008000">FEATURES</span>!
    </strong></p>
    <p><strong></strong>[LEFT]<strong><span style="color: green">Die Suchfunktion steht nicht unter Naturschutz, und darf getrost benutzt werden.</span></strong><br>[/LEFT]<br>[INDENT=4] <img src="http://support.commerce-seo.de/image.php?type=sigpic&amp;amp;userid=64&amp;amp;dateline=1309425110"><br>[/INDENT]</p>

  • Hallo
    Ich habe das Problem nun umgangen, indem ich in der send_order.php eine andere Sendemailadresse im Bereich "send mail to admin" gesetzt habe. (Siehe http://support.commerce-seo.de…B6glich?highlight=hotmail)


    Über einen Providerwechsel denke ich nach und habe meine Empfehlung auch schon an den Betreiber des Shops geschickt.
    Ist bekannt ob andere Hoster auch so einen Kram machen wie Host Europe?


    Nun aber noch zum Modul selbst.
    Das B+W Bezahlmodul scheint mit dem Mehrseitigen Checkoutprozess problemlos zu funktionieren. Wenn es da noch einen Fix zum Einseitigen gibt wäre es richtig klasse. Ich werde das auch entsprechend dem Entwickler des Moduls mal mitteilen.


    Danke an alle für die Tipps.


    Bernd