Version cseov2.1.1.4plusB - SQL Fehler bei Paypalkauf

  • [B]Hallo, habe mir die neue Version installiert. Funktioniert soweit super. Leider bekommt man aber bei der Bestellung per Paypal einen SQL Fehler - bei Vorkasse oder Nachnahme läuft die Bestellung durch:[/B] SQL Fehler [256] (1064) Fehler in der SQL-Syntax. Bitte die korrekte Syntax im Handbuch nachschlagen bei '{1}10' in Zeile 4 Query: SELECT attributes_model FROM products_attributes WHERE options_values_id='10' AND products_id =2{1}10 Beim Aufruf der Datei /shopping_cart.php , PHP 5.2.17-0.dotdeb.0 (Linux) Die Abfrage wurde abgebrochen, kontaktieren Sie den Administrator... [B]Könnt ihr das vielleicht beheben?[/B]
  • Habe dasselbe Problem, PayPal funktioniert nicht mehr seit dem Update nicht mehr (v2.1CE) Mir ist aufgefallen, dass zuerst noch PayPal-Bestellungen gingen (wenn ich mich mit einem bereits registrierten Nutzer angemeldet habe), dann kam aber immer ein Fehler "Kontaktieren Sie den Administrator". Das Problem besteht jeweils bei PayPal sowie bei PayPal Express. Bitte um Rat ;-)
  • direkt mit dem Klick kommt ohne große verzögerung [QUOTE]SQL Fehler [256] (1064) You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '{205}883' at line 4 Query: SELECT attributes_model FROM products_attributes WHERE options_values_id='1022' AND products_id =579{205}883 Beim Aufruf der Datei /shopping_cart.php , PHP 5.3.5 (Linux) Die Abfrage wurde abgebrochen, kontaktieren Sie den Administrator...[/QUOTE] in der Adresszeile steht oben [QUOTE]ADRESSE/shopping_cart.php?products_id=579&cat=0&cPath=0&action=paypal_express_checkout[/QUOTE] das ist an sich der gleiche Fehler wie im normalen PayPal Modul. Ich bin leider nicht Datenbank-bewandert, aber interpretiere ich mit meinen nicht vorhandenen Kenntnissen, dann heißt das so viel wie dass irgendwas falsches ausgewählt wird :-P Der obere Teil wird angezeigt, wenn ich als Admin eine Bestellung darüber abschicken möchte ----------------------------------------------------------------------------------------------- Der Teil hier, wenn ich als "normaler" Kunde bestelle: [QUOTE]Die Abfrage wurde abgebrochen, kontaktieren Sie den Administrator...[/QUOTE] Adresszeile: [QUOTE]ADRESSE/shopping_cart.php?action=paypal_express_checkout[/QUOTE]
  • Also an der 2.1 CE selbst kanns eig nicht direkt liegen habs mal durch getestet bei mir klappts (im live modus) Das einzige was mir grad auffällt ist das bei dir ein leerzeichen drin ist wo kein hin gehört : /shopping_cart.php?products_id=579&cat=0&cPath=0&[COLOR='#FF0000']ac tion[/COLOR]=paypal_express_checkout Gruß
  • Also in der Version [B]cseov2.1.1.4plusB[/B] funktioniert das Paypalmodul definitv nicht. Paypalexpress funktioniert jetzt teilweise. Man muss das Modul installieren, die Paypaldaten eingeben, es dann wieder deaktivieren, dann wieder aktivieren und schon kommt man zumindest auf die Paypalseite. Problem ist noch, dass die berechneten Preise und Versandkosten nicht stimmen. Schade, das keiner eine Vernüftige Lösung anbieten kann. Ich hatte schon einige Bestellabbrüche, da ich momentan im Shop keine Paypalzahlung anbieten kann.
  • ich hab jetzt auch mal probiert die PayPal-Moduldateien aus der alten Version mit denen der neuen zu ersetzen, doch selbst da kommt der fehler. es muss also irgendwie an der datenbank hängen im genauen darin, woher das modul sich die dateien holt. hat denn niemand einen ansatz dafür?!
  • hoi, wenn ich mich recht erinnere war das problem schon mal gelöst... der fehler liegt in der produktübergabe mit attributen[CODE]579[B]{[/B]205[B]}[/B]883[/CODE] da k***t pp ab. wir hatten das vor geraumer zeit mal [I]q'n d[/I] gelöst in dem wir in der xtc_db_query.inc.php auf die product_id und die {-klammern geprüft hatten, und diese dann abgeschnitten hatten. aber andreas hatte zwischendurch noch ne andere lösung, die schieb ich noch nach. greetz, me

    C lets you shoot in your feet, C++ allows you to reuse the bullet.

    Thats NO BUGS, thats FEATURES!

    [LEFT]Die Suchfunktion steht nicht unter Naturschutz, und darf getrost benutzt werden.
    [/LEFT]
    [INDENT=4]
    [/INDENT]

  • Gibt es schon eine Lösung? Ich habe den Fehler auch und mir ziehts grad den ganzen Weihnachtsumsatz deshalb in den Keller :-( Per Admin-Acccount, bzw bestehendem Account funktioniert es - mit neuem Account kommt die oben beschriebene Meldung, dass man den Admin kontaktieren soll.