Problem nach Aktivierung von Gutscheinen

  • Hallo zusammen,
    bisher hat alles gut geklappt. Leider habe ich jetzt ein Problem. Sobald ich das Gutscheinmodul im Feld "Zusammenfassung" installiere komme ich nicht über die Zusammenfassung hinaus.
    Ich bin im Warenkorb komme bis "Zahlungsweise" kann dort alles meinen Wünschen entsprechend auswählen und klicke auf weiter und lande direkt wieder im selben Fenster. Dieser Fehler tritt auf egal ob ich einen Gutschein oder Guthaben offen hab oder nicht. Deinstalliere ich das Modul "Gutscheine" unter Zusammenfassung läuft alles ohne Probleme und ich kann den Kauf abschiessen.
    Danke im Voraus.


    Stefan

  • Hallo zusammen,


    ich benutze CSEO 1.1.0 und habe bei aktiviertem Gutscheinsystem (Admin und Zusammenfassung) das gleiche Problem.
    Nach Auswahl der Zahlungsweise werde ich nicht nach checkout_confirmation.php weitergeleitet, sondern gelange zurück zur checkout_payment.php.
    Hin und wieder wird auf der Seite dann die Fehlermeldung für nicht akzeptierte AGBs geschrieben, diese sind jedoch beim Absenden der Seite markiert.
    Das Problem verschwindet, wenn ot_gv unter Zusammenfassung entfernt wird.


    Ich wäre für eine Lösung dankbar, da das Gutscheinsystem im Shop eingesetzt werden soll.


    Grüße,
    Mantelvampir

  • Merkwürdig, habe aber eine Lösung:


    Suche die Datei:
    templates/xtc-css-001/module/checkout_payment.html


    und in der Datei dort:
    {if $module_gift !=''}<br style="clear:both" /><br />{$module_gift}{/if}


    Ändern auf:
    {if $module_gift !=''}<div><br style="clear:both" /><br />{$module_gift}{/if}


    Dann wird es korrekt angezeigt.

    <p>Wir geben nur Anregungen und Hilfestellung auf Basis unserer Erfahrung, keine Rechtshilfe!<br>\m/('_')\m/</p>

  • Hallo!


    Ich habe auch diese Version seit gestern zum Test installiert.
    Wenn ich als Test-Kunde einige Artikel in den Warenkorb lege und zur Kasse gehe, komme ich ganz normal zu Schritt 2 "Zahlungsweise". Dort wähle ich alles gewünschte aus und setzte den Haken bei AGBs akzeptieren und klicke weiter.
    Nun lande ich auf der gleichen Seite wieder und oben steht:


    "Sie+haben+leider+keinen+Code+eingegeben."


    Der Text ist die Variable "ERROR_NO_REDEEM_CODE", wenn das hilft.


    Gutscheincodes und Rabatt Koupons sind sehr wichtig für mich, da ich diese auch als Anmeldebonus versende.


    Wer kann hier helfen?


    Danke!


    Viele Grüße,
    Michael

  • Hallo zusammen,


    leider bin ich erst jetzt wieder dazu gekommen obigen Tip mit dem <div> auszuprobieren.
    Leider löst dies bei mir nicht das beschriebene Problem. Ich komme weiterhin nicht von der Zahlungsweise-Seite weg, diese wird immer neu geladen.


    Gibt es hier evtl. bereits eine Lösung oder ein Shopupdate, daß dieses Problem beseitigt?


    Für meinen Kunden sind Gutscheine und Rabatte essentiell, da diese als Werbdemaßnahme und zur Kundenbindung eingesetzt werden sollen.


    Besten Dank,
    mantelvampir

  • Hallo!


    Hatte das gleiche Problem und habe mich an den Admin gewandt.
    Hier die Lösung:


    Gehe bitte mal in die Datei:
    includes/modules/order_total/ot_gv.php


    und suche dort mal die Zeilen:
    $_SESSION['error_message'] = urlencode(ERROR_NO_REDEEM_CODE);
    xtc_redirect(xtc_href_link(FILENAME_CHECKOUT_PAYME NT, '', 'SSL'));


    und ersetze diese mit:


    xtc_redirect(xtc_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message='.urlencode(ERROR_NO_REDEEM_CODE), 'SSL'));


    Danach hats bei mir funktioniert.


    Viele Grüße,
    Michael


    http://www.get-X-clusive.de

  • Hallo zusammen,


    leider hat mir obiger Tipp nicht weitergeholfen.
    Jetzt wird zwar die Error-Meldung als GET-Variable an die URL angehangen (und zwar immer, egal ob man einen Gutscheincode auf der shopping_cart.php eingegeben hat oder nicht) aber ich komme trotzdem nicht über die Zahlungsauswahl hinaus.
    Hat hier evtl. jemand eine Idee, wo ich in den Dateien zu Gutschien und Kupon suchen müßte, um mich dem Problem zu nähern?


    Besten Dank,
    mantelvampir

  • Hallo zusammen,
    nach elender Sucherei in diversen PHP-Dateien - wo der Fehler nicht lag - habe ich mir nochmal meine shopping_cart.html zur Brust genommen und dort festgestellt, daß das Gutschein-Einlösen-Formular innerhalb des Warenkorb-Formulars stand, so daß ersteres nie mit den korrekten Parametern abgesendet wurde. Nachdem ich diese Verschachtelung aufgelöst habe, funktioniert es auch mit Kupons/Gutscheinen.


    Jedoch ist auch in CSEO der unter http://blog.techdivision.com/x…gging-und-andere-freuden/ beschrieben Tipfehler in der ot_cupon.php vorhanden. Der sollte in einem nächsten Release mal gefixt werden.


    Eine Frage habe ich dann aber zum Kuponsystem im Allgemeinen noch:
    Kann man einen Kupon-Code einfach verteilen, ohne Ihn an Nutzer gebunden zu haben. Z.B. zur Neukundenwerbung in Zeitschriften oder auf Partys?


    Grüße und Danke an alle,
    Mantelvampir

  • Hallo Mantelvampir,


    ich habe auch bisher alle Infos hier eingefügt und bleibe noch immer in der Schleife stecken wenn ich den Gutschein aktiviert habe. Was meinst du denn mit


    Zitat

    nach elender Sucherei in diversen PHP-Dateien - wo der Fehler nicht lag - habe ich mir nochmal meine shopping_cart.html zur Brust genommen und dort festgestellt, daß das Gutschein-Einlösen-Formular innerhalb des Warenkorb-Formulars stand, so daß ersteres nie mit den korrekten Parametern abgesendet wurde. Nachdem ich diese Verschachtelung aufgelöst habe, funktioniert es auch mit Kupons/Gutscheinen.


    kannst du hier dein Beispiel mal bitte posten?


    Danke

  • Hallo,


    admin : In der mir damals vorliegenden Version von CSEO war der beschriebene Tipfehler in der ot_coupon.php enthalten. Wenn das jetzt nicht mehr der Fall ist, ist ja alles gut :-).


    @Formular: Ich hatte meine shopping_cart.html ein wenig umgeschrieben, damit ich die Coupon-Eingabe direkt unter den Warenkorb platzieren konnte und darunter den 'Zur Kasse'-Button. Jedoch geht das nicht, da der Block der Coupon-Eingabe ein komplettes <form>-Element in der PHP-Datei schreibt, mit eigenem action-Attribut. Sondern man muß den Coupon-Block ans Ende der HTML-Datei stellen.


    Hoffe das hilft weiter.


    Grüße,
    Mantelvampir

  • Hallo zusammen,


    demnächst geht mein CSEO Shop V1.1.1 an den Start.
    Derzeit bin ich am durchtesten und dabei ist mir was aufgefallen:


    Ich logge mich mit meinem Testuser ein, gehe zum Warenkorb (egal ob ich da schon was reingelegt habe oder nicht - Verhalten ist immer gleich) und löse einen Gutschein ein. Das klappt auch, ich kann mir die Details ansehen und der Gutschein wird auch verrechnet beim Einkauf.
    AAAABER: es steht immer über dem Warenkorb die Fehlermeldung "Sie haben leider keinen Code eingegeben" - er wurde aber eingegeben, da er ja auch verrechnet wurde.


    Zudem ist der Fehler mit der falsch berechneten Mehrwertsteuer auch noch in der V1.1.1 drin.


    Wie bekomm ich denn jetzt diese Fehlermeldung weg, daß ich keinen Gutscheincode eingegeben hätte?


    Viele Grüße,
    Michael

  • In der v 1.1.1 ist alles schick... ;)


    HTML
    1. .
    2. .
    3. {$FORM_END}
    4. <br /><hr /><br />
    5. {$MODULE_gift_cart}
    6. </div>


    Das Modul liegt unterhalb des Warenkorb Form-Elements.

  • Also wenn der Bug bei Dir drin ist, welche Version nutzt Du denn?


    Habe genau das gleiche Problem: Kupon wird zwar beim finalen Checkout angezeigt, aber im Warenkorb nicht
    und auf Check-Out Seiten auch immer die Meldung "Sie haben leider keinen Code eingegeben."


    (Des weiteren lädt er mir zwar das kleine Beschreibungsfenster des Kupons, aber die Hauptseite wird auf eine
    nicht existierende Seite umgeleitet, auf unserer Seite sieht das so aus:

    PHP
    1. http://shop.buyplanet.de/%3Ca%20style=


    auch der Link sieht komisch aus...->


    PHP
    1. <div class="headerMessage"><b>Gutschein</b> erfolgreich <b>eingel&ouml;st</b>, <a href="&lt;a style="cursor:hand" onclick="javascript:window.open('http://shop.buyplanet.de/popup_coupon_help.php?cID=10', 'popup', 'toolbar=0,scrollbars=yes, width=350, height=350')">">... <b>Details</b> zu Ihrem Coupon</a></div>


    =>

    PHP
    1. Gutschein erfolgreich eingelöst, ">... Details zu Ihrem Coupon


    - Ist bei mir die Commerce:SEO Version 1.1.1 inkl. letztem Patch
    - Denke mir da liegt da der Fehler in der inc\xtc_collect_posts.inc.php
    (habe das getestet und das schien die Quelle zu sein)



    Irgendeine Idee? :confused:

  • Doch hat er ;) . Das ist ein Fehler in der Session. Die Fehlermeldungen/Erfolgsmeldungen werden in der Session gesammelt aber nicht wieder korrekt entfernt.


    Öffne die checkout_confirmation.php und suche:

    Code
    1. if (!isset($_SESSION['all_checkout_checks_ok'])) {



    Füge DAVOR ein:

    Code
    1. unset($_SESSION['error_message']);



    Das sollte das Problem lösen. Ist in der v2 schon gefixt worden.