Datenbankproblem?

  • Hallo Leute,


    habe seit einiger Zeit schon das PayPal-Problem, weshalb ich langsam darauf schließe, dass es u.U. irgendwas mit der Datenbank sein kann.
    Vorab, ich benutze die CE Version, neuste Updates.


    Hier eine kleine Liste der Fehler, die wirklich störend sind, ich jedoch auch nach langem Suchen nun nicht beheben konnte:


    - Unter "Bestellungen" -> Bestellung, die mit PayPal bezahlt wurde (Express) -> über dem Zahlungshinweis-Feld kommt diese Fehlermeldung

    Zitat

    Deprecated: Function mysql_list_tables() is deprecated in /kunden/272722_36358/webseiten/admin/includes/classes/class.paypal.php on line 330


    - beim Checkout durch PayPal-Express wird z.B. anstatt Versandkosten nur "Differenz" angezeigt sowie wird anstatt 3,90 für Versand 6,90 angegeben


    - beim Installieren sowie Deinstallieren bekomme ich diverse Fehlermeldungen, jedoch lassen sich die Module im Endeffekt trotzdem installieren:

    Zitat

    Deprecated: Function mysql_list_tables() is deprecated in /kunden/272722_36358/webseiten/includes/modules/payment/paypalexpress.php on line 240


    Deprecated: Function mysql_list_tables() is deprecated in /kunden/272722_36358/webseiten/includes/modules/payment/paypalexpress.php on line 252


    Warning: Cannot modify header information - headers already sent by (output started at /kunden/272722_36358/webseiten/includes/modules/payment/paypalexpress.php:240) in /kunden/272722_36358/webseiten/admin/includes/functions/general.php on line 130


    - das normale PayPal-Modul, lässt sich zwar installieren, beim normalen Checkout geht's aber nicht weiter, das Fenster spuckt nur als Info aus, dass man eine Zahlungsmöglichkeit auswählen soll. Per Vorkasse gehts dann weiter ...


    Habt Ihr 'ne Idee? Wollte nur ungern auf PayPal verzichten, aber momentan macht das unheimliche Probleme.


    Liebe Grüße und einen schönen Samstag wünscht Euch
    Eric

  • Hallo Eric und auch dir einen schönen Samstag
    Eigentlich sind das nur Warnungen, meine Frage die du dem Thread zufügen solltest, nutzt du PHP 5.3 und welche MySQL Version nutzt du? Diese Angaben helfen den Leuten die eine Antwort haben im Vorfeld.


    Viele Grüße

  • Glaube daran liegt es :-P


    DB-Version: 5.1.4
    MySQL: 5.1.39
    formatiert in: UTF-8 Unicode (utf8)


    Muss die Version geändert werden? Wie mache ich das dann mit dem Export der bisherigen Datenbank - ist das valide?

  • Es wäre für mich jetzt kein Problem, eine andere Version von PHP einzustellen, nur welche, das ist die Frage, da anscheinend auch andere Versionen Probleme bereiten.


    Liebe Grüße