Fehlermeldung bei falschem Link

  • Wenn der Kunde bei Go..le einen alten Link anklickt kommt leider statt 404 diese Fehlermeldung:


    Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/www/web67/html/akkushopneu/commerce_seo_url.php on line 40

  • Hallo


    Bei mir kommt folgende Meldung wenn man einen falschen link eingibt.


    Warning: mysql_num_rows() expects parameter 1 to be resource, boolean given in /var/customers/webs/...../commerce-seo-v2/Shopdateien/commerce_seo_url.php on line 40


    Warning: Cannot modify header information - headers already sent by (output started at /var/customers/webs/....../commerce-seo-v2/Shopdateien/commerce_seo_url.php:40) in /var/customers/webs/...../commerce-seo-v2/Shopdateien/commerce_seo_url.php on line 110


    wo muss ich was ändern?


    Danke


    Gruss Steffi

  • vieleicht seo url deinstall dan wider install und dan laufen/starten lassen?


    Habe es noch nicht gesehen wen ich einer unsin link eingebe geh es gut, in google steht mein test fp11plus nicht sollte auch nicht


    Geben bei euch eigene unsin links doch einer 404?

  • so habe auf einer anderen url cseov2.0.11ce komplett neu installiert.
    commerce:SEO URL v1 nach Anleitung ausgeführt.


    auch hier tritt dieser Fehler auf:


    Warning: mysql_num_rows() expects parameter 1 to be resource, boolean given in /var/customers/webs/...../commerce-seo-v2/Shopdateien/commerce_seo_url.php on line 40


    Warning: Cannot modify header information - headers already sent by (output started at /var/customers/webs/....../commerce-seo-v2/Shopdateien/commerce_seo_url.php:40) in /var/customers/webs/...../commerce-seo-v2/Shopdateien/commerce_seo_url.php on line 110


    habe jetzt herausgefunden das in der mysql Datenbank folgende Tabelen fehlen:


    commerce_seo_url_names
    commerce_seo_url_personal_links


    Wie kann ich das Problem lösen?


    Vielen Dank vorab



  • Sind vor Plus version gedacht ( denke ich) die hat personal links, deswegen geht es bei mir gut.

  • Alle FP´s wurden eingespielt, die sql auch.


    das Problem besteht auch bei Neuinstallation von cseov2.0.11ce



    Sorry meine gibt zum download den fp11 ce, blog, base und plus version, vielleicht dieser datei vergleichen auf die die in den von Neuinstallation von cseov2.0.11ce dir sind, könnte sein dass etwas von andere Version dazwischen geraten ist.

  • hmm...


    installiere dir den fp 10 auf einem dummy server und mach einen sql dump der beiden tables und die importierst du dann in die fp11 ich denke das bei der cs version die funktionen wohl vorhanden aber nicht nutzbar sind ...

  • vieleicht liegt es ja am sever oder an der datenbank
    hier mal die daten:


    HTTP Server: Apache/2.2.16 (FreeBSD) mod_ssl/2.2.16 OpenSSL/0.9.8k DAV/2 PHP/5.3.3 with Suhosin-Patch
    PHP Version: 5.3.3 (Zend: 2.3.0)


    Datenbank: MySQL 5.0.90

  • Es sieht so aus, als ob die Meldung nur bei einer zu hohen Fehlerausgabe seitens PHP kommt. Ich sehe den Fehler maximal im error_log

    <p>Wir geben nur Anregungen und Hilfestellung auf Basis unserer Erfahrung, keine Rechtshilfe!<br>\m/('_')\m/</p>