Blog: Riesenprobleme

  • Hallo!
    Ich arbeite für einen Kunden an einem Shop mit der v2-plus-Version und dem aktuelleste fix-Pack.


    Zur Historie: Ich habe nach der Installation die commerce:seo URL v1 (SUMAfreundliche URLS) aktiviert, diversen Content und ein paar Artikel eingepflegt. Alles funktionierte bis dahin ganz gut. Die URLS wurden korrekt angezeigt. Nur seit ich versucht habe, Inhalte in den Blog einzupflegen, tillt das System. Folgende Fehlermeldungen:


    - Wenn ich im Blog auf "Neues Thema" klicke, erscheint

    Code
    1. SQL Fehler [256] (1052) Column 'categories_id' in where clause is ambiguousQuery: SELECT fi.id, fi.title AS item_title, fi.name AS item_name, fi.meta_title, fi.meta_keywords, fi.meta_description, fi.lenght, fc.titel AS categorie_name, fi.position AS position, fi.description AS description, fi.categories_id AS categories_id FROM blog_items fi, blog_categories fc WHERE fi.id = '0' AND fi.language_id = '1' AND categories_id = fc.idBeim Aufruf der Datei /admin/blog.php , PHP 5.2.13 (Linux)Die Abfrage wurde abgebrochen, kontaktieren Sie den Administrator...


    - Wenn ich im Blog auf "Neue Kategorie" klicke erscheint folgende Fehlermeldung

    Code
    1. Fatal error: require() [function.require]: Failed opening required '/XXX/XXX/XXX/XXX/lang/Array/admin/Array.php' (include_path='.:/usr/local/lib/php') in /xxx/xxx/xxx/xxx/admin/includes/application_top.php on line 245


    - Das Kuriose: Beim SUMA-Modul commerce:seo URL v1 wird mir permanent der btn "Installieren" angezeigt. Wenn ich drauf klicke, passiert nix. Ich kann weder bearbeiten, noch deinstallieren.


    Ich bin völlig ratlos, zumal jetzt ca. 2 Tage Arbeit drin stecken.


    Ich bitte um Hilfe
    Hartmut

  • ...bei mir dasselbe



    @siekira: am sql liegst nich, is drin (oder da fehlt was/ ist fehlerhaft).... da läuft was anderes schief, siehe Pfad:


    /XXX/XXX/XXX/XXX/lang/Array/admin/Array.php


    apropos sql .... beim _insert into emails_ gibts nen prima Server Error500, das hat man auch nicht oft

  • Einen 500 bei einem SQL ist Technisch nicht möglich. Sorry das ist was anderes. Dann solltest Du dir die richtige Software aussuchen. Klappt hier mit MySQLDumper 1.24 und dem eben geladenen phpMyAdmin ohne Probleme!


    PS: Wir haben das Fixpack nochmal geupdatet. Leider will der Kausch(admin) nicht auf mich hören und gibt dem Pack keine Versionsnummer. Demnach müsst Ihr anhand des Datums/Größe schauen welche Version ihr davon habt.


    Für die Plus Version ist das Fixpack in dem Download vom Shop drin. Einfach noch mal runterladen.

  • @siekiera: .... hmm dann hab ich anscheinend komische Technik, aber wie du siehst geht technisch doch so einiges .....siehe Pic
    bei diesem SQL (aus Update.txt / fp5):


    HTML
    1. INSERT INTO emails VALUES (NULL, 'new_password', 1, 'ihre@mail-adresse.de', 'Kundenservice', 'ihre@mail-adresse.de', 'Kundenservice', 'Ihr neues Passwort', '', '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">\r\n<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" xml:lang="de" lang="de">\r\n<head>\r\n<meta http-equiv="Content-Type" content="text/html;charset=utf-8" />\r\n<title>Neues Passwort</title>\r\n{literal}\r\n<style type="text/css">\r\nbody, table {font-size:11.5px; font-family:Helvetica, sans-serif;color:#444}\r\ntable.outerTable {border: 1px solid #ccc}\r\ntd.TopRightDesc {letter-spacing: 1px; font-weight: 600}\r\n.lightBackground td {color:#6d88b1;background: #f1f1f1}\r\n.ProductsTable td {color:#6d88b1;background: #f1f1f1}\r\n.ProductsAttributes td, .ProductsName {background: #ffffff}\r\n.bt {border-top:1px solid #ccc}\r\n.bb {border-bottom:1px solid #ccc}\r\n.bl {border-left:1px solid #ccc}\r\n.br {border-right:1px solid #ccc}\r\n.fs85 {font-size:85%}\r\n</style>\r\n{/literal}\r\n</head>\r\n<body>\r\n<table width="90%" border="0" cellpadding="10" cellspacing="0" align="center" class="outerTable">\r\n <tr>\r\n <td>\r\n <table width="100%" border="0" cellpadding="0" cellspacing="0">\r\n <tr>\r\n <td width="50%">\r\n <img src="{$logo_path}logo.gif" alt="" />\r\n </td>\r\n <td width="50%" class="TopRightDesc" align="right">\r\n Neues Passwort\r\n </td>\r\n </tr>\r\n </table>\r\n </td>\r\n </tr>\r\n <tr> \r\n <td><p><b>Passwort geändert!</b></p>\r\n Sie erhalten diese Mail, weil Sie ein neues Passwort angefordert und eingerichtet haben.<br />\r\n Bitte loggen Sie sich mit folgendem Passwort und Ihrer E-mail Adresse bei uns ein und ändern Sie Ihr Passwort in Ihrem Account wie Sie es wünschen.\r\n <br />\r\n </td>\r\n </tr>\r\n <tr class="lightBackground">\r\n <td><b>Ihr neues Passwort:<br>\r\n </b>{$NEW_PASSWORD}\r\n </td>\r\n </tr>\r\n <tr>\r\n <td>\r\n <p>Wir wünschen Ihnen weiterhin viel Spaß mit unserem Angebot!</p>\r\n </td>\r\n </tr>\r\n</table>', 'Passwort geändert!\r\n\r\nSie erhalten diese Mail, weil Sie ein neues Passwort angefordert und eingerichtet haben.\r\nBitte loggen Sie sich mit folgendem Passwort und Ihrer E-mail Adresse bei uns ein und ändern Sie Ihr Passwort in Ihrem Account wie Sie es wünschen.\r\n\r\nIhr neues Passwort: {$NEW_PASSWORD}\r\n\r\nWir wünschen Ihnen weiterhin viel Spaß mit unserem Angebot!', '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">\r\n<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" xml:lang="de" lang="de">\r\n<head>\r\n<meta http-equiv="Content-Type" content="text/html;charset=utf-8" />\r\n<title>Bestellbestätigung</title>\r\n{literal}\r\n<style type="text/css">\r\nbody, table {font-size:11.5px; font-family:Helvetica, sans-serif;color:#444}\r\ntable.outerTable {border: 1px solid #ccc}\r\ntd.TopRightDesc {letter-spacing: 1px; font-weight: 600}\r\n.lightBackground td {color:#6d88b1;background: #f1f1f1}\r\n.ProductsTable td {color:#6d88b1;background: #f1f1f1}\r\n.ProductsAttributes td, .ProductsName {background: #ffffff}\r\n.bt {border-top:1px solid #ccc}\r\n.bb {border-bottom:1px solid #ccc}\r\n.bl {border-left:1px solid #ccc}\r\n.br {border-right:1px solid #ccc}\r\n.fs85 {font-size:85%}\r\n</style>\r\n{/literal}\r\n</head>\r\n<body>\r\n<table width="90%" border="0" cellpadding="10" cellspacing="0" align="center" class="outerTable">\r\n <tr>\r\n <td>\r\n <table width="100%" border="0" cellpadding="0" cellspacing="0">\r\n <tr>\r\n <td width="50%">\r\n <img src="{$logo_path}logo.gif" alt="" />\r\n </td>\r\n <td width="50%" class="TopRightDesc" align="right">\r\n neues Passwort\r\n </td>\r\n </tr>\r\n </table>\r\n </td>\r\n </tr>\r\n <tr> \r\n <td><p><font size="2" face="Verdana, Arial, Helvetica, sans-serif"><b>Passwort geändert!</b></p>\r\n Sie erhalten diese Mail, weil Sie ein neues Passwort angefordert und eingerichtet haben.<br />\r\n Bitte loggen Sie sich mit folgendem Passwort und Ihrer E-mail Adresse bei uns ein und ändern Sie Ihr Passwort in Ihrem Account wie Sie es wünschen.\r\n </p><br />\r\n </tr>\r\n <tr class="lightBackground">\r\n <td><b>Ihr neues Passwort:<br>\r\n </b>{$NEW_PASSWORD}\r\n </td>\r\n </tr>\r\n <tr>\r\n <td>\r\n <p>Wir wünschen Ihnen weiterhin viel Spaß mit unserem Angebot!</p>\r\n </td>\r\n </tr>\r\n</table>', 'Passwort geändert!\r\n\r\nSie erhalten diese Mail, weil Sie ein neues Passwort angefordert und eingerichtet haben.\r\nBitte loggen Sie sich mit folgendem Passwort und Ihrer E-mail Adresse bei uns ein und ändern Sie Ihr Passwort in Ihrem Account wie Sie es wünschen.\r\n\r\nIhr neues Passwort: {$NEW_PASSWORD}\r\n\r\nWir wünschen Ihnen weiterhin viel Spaß mit unserem Angebot!', 12345612);



    [ATTACH=CONFIG]124[/ATTACH]



    ich würde ja gerne ds neue fp5 runterziehen, ich habe aber die V2plus ohne Konto bestellt und das letzte fp5 schon per mail bekommen. Krieg ich das nun auch wieder auf diese Weise ? Wäre schön, wenn da was dauerhaftes geht, will da nicht bei jedem fp nachfragen und nerven müssen. Nervt mich und euch wahrscheinlich auch.

  • @siekiera


    Hallo! Ich hatte die Plus-Version inkl. fixpack 5 am Abend des 27.8.10 kurz nach der Veröffentlichung des fixpacks runtergeladen. Laut Herrn Kausch war da schon alles drin.


    Zu Deinem Beitrag:
    Heißt das also,
    a) dass ich den Download jetzt noch mal ausführen soll?
    b) die fixpack-Daten noch mal uploaden muss?
    c) oder alle Shop-Daten noch mal uploaden soll?
    b) Und müsste ich den Inhalt der "update.txt" unter SQL in phpmyadmin nochmals ausführen?


    Ich bitte dringend um Hilfe. Ich hab den admin schon mehrfach gebeten, eine Lösung zu anzubieten. Ohne Erfolg.


    hattu_s

  • @hartmut: das fp5 wurde wohl aktualisiert, also erneut runterladen..... brauchst wahrscheinlich nur die blog-dateien austauschen


    vergiss mal die sql von mir grade, das hat nix mit dem blog zu tun.

  • @siekiera


    Hallo siekiera.


    Ich habe die aktuellesten Shop-Dateien noch mal runtergeladen (mit blog.php vom 31.8.2010, 11.25 Uhr), alles aufgespielt, neue DB eingebunden. Wieder das gleiche Problem, wenn ich im blog-Modul eine "neue Kategorie" erstellen will (siehe Post oben). Einziger Unterschied: Im Admin-Bereich wird mir unter "blog" der Button "neues Thema" nicht mehr angezeigt. Die sql-Befehle der "update.txt"-Datei habe ich allerdings nicht ausgeführt, da dies beim letzten Versuch meine alte DB zerschossen hat. Nix wurde mehr angezeigt.


    Mein Kunde wird langsam ungeduldig (ich auch, habe mehr als 2 Tage Arbeit investiert). Der Kunde hat das 299-Euro-Paket nur wegen des Blogs gebucht. Und er wird für eine Leistung, die nicht funktioniert, nicht bezahlen. Ich bitte noch mal herzlich um Hilfe, da sich Herr Kausch trotz mehrfacher Bitte nicht bewegt.


    Hartmut

  • An alle Interessierten: Ich habe das Blog-Problem nach langem Rumprobieren selbst gelöst. Ich musste die PHP-Version auf 5.3 umstellen. Vorher lief 5.2.11, was ja eigentlich hätte reichen müssen, glaubt man den von den Entwicklern vorgegebenen Systemvoraussetungen ("mind. PHP 5.1.x"/ siehe Anhang-Screenshot).



    De facto funktioniert der Blog zumindest auf meinen Domainfactory-Servern nicht mit einer 5.2.-Konfiguration. Nun, da der Shop funktioniert, ist alles gut. Es sei deutlich gesagt: Das Ding ist prima!!! Aber es bleibt ein fader Beigeschmack: Wer 299 Euro für die Plus-Variante verlangt, muss zumindest bei "Bezahl-Kunden" für einen zielführenden Support sorgen. Und da hat sich der Anbieter nicht gerade mit Ruhm bekleckert. FTP-Zugang und Shop-Login hatte ich auf Wunsch von Webdesign-Erfurt zwecks Fehlersuche zur Verfügung gestellt. Passiert ist nix. Das bin ich bspw. von xtc-Plugin-Anbietern anders gewohnt. Noch mal: Diese Kritik soll nicht das Produkt selbst schmälern, es geht um die Unterstützung der Kunden, die techn. Probleme haben. Vielleicht tragen offene Worte zur Verbesserung bei.


    uhenke: Versuchs mal mit der Änderung der PHP-VErsion. Viel Erfolg!


    Hartmut


    commerce-seo.de/support/wcf/attachment/126/

  • Wir haben nicht nur 50 oder 100 Kunden. Da kann sich die Supportzeit schon mal ein bissel erhöhen. Da ich der Programmierer bin, versucht Herr Kausch mir schon die restlichen Arbeiten/Kunden "fern" zu halten. Ansonsten könnte ich nicht mal ein Fixpack schreiben. Wir sind also zu zweit und bekommen pro Tag mehrere 100 Mails mit Anfragen, Problemen und sonstigem Inhalt.


    Und wenn ich dann nach der Arbeit noch Zeit finde, beantworte ich Fragen in unserem Forum, von Leuten, denen es meistens zu viel ist Google mal zu bemühen.


    Ich habe keine Befehle im Blog die nur unter PHP 5.3 laufen würden. Auf sowas achte ich.

  • @siekiera: ja ne is klar, das glaub ich jetzt sofort..... es liegt NICH an DF oder an nem verstümmelten phpmyadmin (was mich doch auch sehr gewundert hätte) sondern an uncodierten umlauten, eure update.txt mit nem einfachen Editor geöffnet bringt da leider nur Schrott und verursacht nen 500er .... aber ist auch egal, ich hatte mir eh schon selber geholfen


    was den Blog betrifft hat Hartmut leider Recht, auch bei mir --> erst ab php 5.3.0 läuft der Blogadmin, darunter mit genannter Fehlermeldung, der Blog ansich läuft auch mit 5.2.x, zumindest kann ich Kommentare schreiben ...... wäre prima wenn Du das noch 5.2 kompatibel machen könntest...


    @hattu: danke für den Tip ...



  • Hatte ich das gleiche Problem, und geholfen hat mir die Umstellung der PHP Version auf 5.3, dank diesem Beitrag hier! Danke
    Und der Support für Kunden der Plus Version ist leider zur unprofessionell, und erfordert noch viel Übung im Umgang mit der Kundschaft

  • Das hat mit der PHP Version nichts zu tun.


    bukata2010
    Du! 1 Woche hier im Büro. Jeden Tag 20-50 Kunden die einen Shop aufsetzen wollen und das Wort Browser nicht kennen. Ich geb Dir 3 Tage...


    Glaub mir, nach 3 Jahren lässt die gute Laune langsam nach. Wir sind übrigens seit 10 Jahren im Geschäft.
    Aber ich muss fast jeden Tag auf's neue mit unbedarften "Experten" diskutieren. Irgendwann ist ein Punkt erreicht, da machste einfach nur noch, der Rest ist dann egal...

  • Tja auf 5.3 kann ich leider nicht umstellen. Da laufen noch 30 andere Projekte drauf. Hab folgenden Fhler beim Aufruf eines Blogbeitrages im Frontend.


    SQL Fehler [256] (1140) Mixing of GROUP columns (MIN(),MAX(),COUNT(),...) with no GROUP columns is illegal if there is no GROUP BY clause


    Query: SELECT blog_id, vote_nr, SUM(vote_nr) AS votes_gesamt FROM blog_vote WHERE blog_id = '1'


    Beim Aufruf der Datei Werbeartikel-Trends/Neue-Trends , PHP 5.2.6-1+lenny9 (Linux)


    Die Abfrage wurde abgebrochen, kontaktieren Sie den Administrator...



    ps: Fixpack aktuell 2.07

  • Hallo,
    leider besteht das Blog Problem noch immer. Wenn eine neue Kategorie erstellt wird erscheint folgende Fehlermeldung:



    Fatal error: require() [function.require]: Failed opening required '/www/xxx.com/xxxx/xx/xx/lang/Array/admin/Array.php' (include_path='.:/usr/local/lib/php') in /xxxx/xxxx/xxxx/xx/xx/admin/includes/application_top.php on line 245


    Es scheint hier eine Datei zu fehlen. Würde mich freuen wenn dass Problem mal gelöst wird.


    Beste Grüße


    rob.