Darstellungsprobleme bei Opera, Chrome und IE

  • Hallo,


    ich habe bei meinem Shop www.teelirium.de festgestellt, dass der Shop im IE, im Opera und im Chrome Browser (jeweils aktuelle Version) nicht korrekt dagestellt wird. Beim Aufruf der Startseite fehlen der Header und die beiden äußeren Spalten, sodass keine Navigation möglich ist. Dies tritt nicht immer beim Aufruf der Seiten auf, aber in 90% der Fälle fehlen Header und die Spalte links und rechts. Beim Firefox (meinem Standardbrowser) funktoniert alles super. Ich kann nicht nachvollziehen, ob das bei anderen Usern auch so ist - und hoffe es nicht - aber was kann da das Problem sein und was kann ich dagegen tun???


    Danke für die Antworten und viele Grüße aus Heidelberg
    Florian
    www.teelirium.de

  • Ist sicher nur eine Klenigkeit in deinem stylesheet.


    Die Div Container verschieben sich
    die Spaltenbreite Links - Mitte - Rechts incl.der Abstände (padding oder margin) darf nicht mehr als 100% sein.

  • Hallo,


    danke erstmal für die Antworten, so weiss ich schonmal, wo ich ansetzen muss mit der Suche. OK, also liegt es wohl am CSS, das ich irgendwie versaut habe. Natürlich weiss ich nicht mehr, was und wo ich da verstellt habe. Liest hier ein fähiger CSS Profi mit, der sowas analysieren und beheben kann? Ich habe nämlich von CSS überhaupt keine Ahnung. Natürlich gegen Bezahlung. Wäre mir schon wichtig, dass das behoben wird.


    Viele Grüße
    Florian
    www.teelirium.de

  • Hallo Florian,


    kennste das:

    Code
    1. <link href="file:///C:\DOKUME~1\FLORIA~1.ROS\LOKALE~1\Temp\msohtml1\01\clip_filelist.xml" rel="File-List"/>

    oder das

    Das ist alles Schrott aus Deinem Template. Damit zerhaust Du Dir das komplett.


    Mach mal auf dieser Seite mit Firefox den Quellcode unterhalb des "Matcha cooking Basic" auf. Da sind vielleicht leckere Sachen drin... Da hört dann im IE auch die Seite auf.


    Grundregel eines Shopbetreibers: KOPIERE NIEMALS TEXT AUS WORD ODER OPEN OFFICE OHNE ES KORREKT ZU IMPORTIEREN. Also über die Word-Importfunktion des Editors oder den Weg über einen Editor wie Notepad++.


    Heißt im kurzen. Alle Produktbeschreibungen öffnen. Im Editor in die Quellcode Ansicht wechslen. Ist dort so ein komischer Code zu finden, zurück zur normalen Ansicht, STRG+A, STRG+V in Notepad++, STRG+A im Notepad++ --> STRG+A im Shop Editor. Nun ist der Text "sauber". Denn alles was wir nicht sehen, sieht ein Notepad++ auch nicht.

  • Boah, das ist doch nicht wahr.... was hab ich denn da für eine Sch... eingebaut!!!! Tja, das kommt davon, wenn man mit Copy&Paste aus Word die Beschreibungen übernimmt. Das war mir aber eine Lehre - so einen Schwachfug mach ich nicht mehr. Aber echt krass, dass dann die ganze Seite nicht mehr korrekt angezeigt wird.


    Habe alle Beschreibungen angepasst, den Word-Rotz rausgenommen und nun läufts wieder - glücklicherweise!!!


    Danke, danke, danke für die Hilfe - ohne den echt guten, kompetenten und netten Support hier im Forum hätte ich schon längst das Handtuch geworfen!!!


    Viele Grüße!
    Florian
    www.teelirium.de